Could not find /dev/disk/by-id/...

Hello. After installing OpenSuse 11.1 I had some problems with my wireless internet connection. After a long time of trying to find the solution I decided to install madwifi. Unfortunately after reboot my Linux refused to start. When I switch to console when booting I get tens of errors that pass so quickly that I can’t even read them and then a message appears:

Could not find /dev/disk/by-id/ata-Hitachi(…some letters and numbers…)-part3
Exiting to /bin/sh

I’ve been already fighting with this problem for about 3 hours and unfortunately didn’t find any solution… Could anybody help me?

This is about partition 3 of your disk.

Did you try to see if /dev/dik/by-id…-part3 exists?

ls -l /dev/disk/ata-Hit*-part3

Can also you post the output of

fdisk -l

and of

cat /etc/fastab

For the moment I can not see any connection bwteen you installing madwifi (using YaST?) and this.

First of all: I managed to find the source of this problem :). Here’s what I did.

I forgot to tell you that I had the same problem with Ubuntu distro. I installed it a few days ago, it worked well and then I downloaded the newest updates. After reboot the same problem appeared as now…

I couldn’t find any solution on the internet so I downloaded OpenSuse, it also worked perfect (except my WiFi…). Then I installed madwifi (using Yast), rebooted - and this problem appeared.

Here’s what I got when I typed these three commands:

ls -l /dev/disk/ata-Hit*-part3

He found it and explained what it is ;).

fdisk -l

sh: fdisk: command not found

cat /etc/fstab

cat: /etc/fstab: No such file or directory

Then I put my Ubuntu Live CD (unfortunately I left OpenSuse in another town) to see how it would behave. When I got the partition manager it seemed a bit foolish - he could just see one big (empty) disk, without any partitions.

Then I started Ubuntu from my Live CD and typed again these three commands:

ls -l /dev/disk/ata-Hit*-part3

He again found it and explained what it is ;).

fdisk -l

Cannot open /dev/sda

cat /etc/fstab

aufs / aufs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0

Then it came to me that two weeks ago I decided to lock my hard disk with a password (in bios). Of course I type this password when my computer boots but I decided to try to remove it. Surprisingly - OpenSuse had no problems with booting…

So I’ve got a few questions now:

  1. What’s the difference between the console that appeared in OpenSuse (when it tried to boot) and the one in Ubuntu? Why did Ubuntu know what fdisk is and OpenSuse not?

  2. Why did OpenSuse have no problems with booting after a fresh install and refused to work after installing madwifi?

  3. What should I do to lock my hard disk and boot Linux without any problems? :stuck_out_tongue:

I do not understand you answer on my question for more information at all. What do you mean by “He found it and explained what it is”? I want to see something like:

boven:~ # ls -l /dev/disk/by-id/scsi-SATA_Hitach*-part3
lrwxrwxrwx 1 root root 10 Oct 31 09:55 /dev/disk/by-id/scsi-SATA_Hitachi_HDT7250_VFJ201R23XUEXW-part3 -> ../../sda3
boven:~ #

(this is on my system, so it differs from what you should get).

Als when you get :

$ fdisk -l
sh: fdisk: command not found

you forgot that all these commands should be done by root. Sorry I forget to tell you this, I thought it would be obvious.

Please try again so we can have the information needed to discuss your problem.

Well, I meant that I got something like that. Here’s exactly what this command prints:

lrwxrwxrwx 1 root 9 Oct 31 12:17 dev/disk/by-id/ata-Hitachi_HTS5S1612J9SA00+SB2E41H7H221GE -> ../../sda

I did try to execute them by root but when I type:

sudo fdisk -l

I get:

sh: sudo: command not found
sh: su: command not found

I your first post you takled about an error saying somethhing was mmissing in a thing ending in -part3.

In my first answer asked you to do:

ls -l /dev/disk/ata-Hit*-part3

Then you answred with telling me there was some output.

Then I told you that that is not very informative, but that I want to **see **the output. I offered you an example from my system that:

  1. showed explicitly an ending of** -part3** to make it easy for you;
  2. showed you how to copy/paste the lines containing the given command and the output generated by it, this so I can check if you did what I asked for.

Now what you do is:

  1. NOT a copy/paste (or carefull typing exactly) what I gave you, but you are leaving out the -part3 for no apparent reason.

Am I glad, no I am not, I am wasting my free time on this >:(

What I seem to miss also is how you are loged in in the system. Are yyou at the real console (the black screen whichshows only character)? And when yes, can you log out, and then log in directly with root and then do what I asked for? I addmit, that in that case it is impossible to do copy/past. But please write down the output of cat /etc/fstab and fdisk -l as correct as possible.

OK, that was my fault, I made a mistake, I’m sorry. Instead of typing:

ls -l /dev/disk/ata-Hit*-part3

I just wrote

ls -l /dev/disk/ata-Hit[tab]

The rest of the name filled automatically and I missed the “part3” part.

To sum up, in /dev/disk there’s no ata-Hit*-part3, but this:

lrwxrwxrwx 1 root 9 Oct 31 12:17 dev/disk/by-id/ata-Hitachi_HTS5S1612J9SA00+SB2E41H7H221GE -> ../../sda

I never get to the logging window. As I wrote in my first post, when Linux boots lots of error messages appear just to tell me that it’s “exiting to /bin/sh”. So I don’t get what you mean by saying “log out and then log in directly with root”.

It seems that there are no partitions found on the disk and that nothing is there.

We need the fdisk -l ouput to know for sure if there are still partitions there.
You can get this by booting from the CD/DVD you used to install openSUSE. When the boot menu shows go down to something like “rescue system” and hit the return key. It will boot a small live system and you will be root there. Try the fdisk -l from there. Check if there is an sda (I suppose there will be) and then if there are any sda1 sda3 (and maybe more lines). I admit that writing down this might be tedious. Maybe you can make a camara picture and post the picture.