could not find /dev/disk/by-id/...

Hi All,

Sorry about my first post being so long.

I’m your average M$-XP user and very new to linux and have just played a little with debian and opensuse in virtualbox on XP64.

Well I decided to set up a dual boot with XP64 and opensuse11.1, but I seem to have hit a wall.

When the system boots, I get “could not find /dev/disk/by-id/raid-ddf1_ARY2-part*” “want me to fall back to /dev/mapper/ddf1_ARY2_part* (Y/n)” and then nothing after entering either y or n.

After 3 days of re-installing, searching the forum, google, and finally, I think my problem is related to this bug report, as my system has hardware raid and it only occurs after a full system/kernel update. I have installed it 3 times now, the first time I selected additional packages and updated everything during the install and didn’t get past the first boot. The second time I installed using the default configuration and didn’t update anything, just to speed the install up, and it installed OK and booted successfully into the Gnome desktop where I just poked around briefly before finding the package manager and updating all the packages marked for update, after which I got the message to reboot for kernel updates to take effect, so I did and got the above error. At this point I still didn’t realise it was related to the updates and thought it might have been related to the partition tables created during the first install so during the third install I created new tables and partitions via the expert partitioner during the install, and again everything installed OK. This time I rebooted a few times in and out of XP and opensuse and everything appeared fine, except the sound and second monitor but that’s something to be fixed later, then I updated and here I am with the same problem trying to find out what to do next.

My system is as follows;
Supermicro 7045A-3 using an adaptec AIC-9410w sas/sata controller. Super Micro Computer, Inc… - Products | SuperWorkstation | Tower | 7045A-3 / 7045A-3B
4 seagate hard drives, 1 and 2 (320GB 7200.10) set up in raid-1 with XP64 installed and 3 and 4 (500GB 7200.12) set up in raid-1 with opensuse11.1(Gnome) installed.
8GB DDR2-667 FB-DIMM, nvidia quadro fx3500, SB Audigy SE.

I can see from the bug report it can be fixed manually, but can’t figure out what to do from the description, so I thought if I posted here and asked someone with a bit of experience to take a look at the above bug report, they could probably decipher what to do from the bug report description and point me in the right direction.

Anyway I’ve rambled on long enough. Any help would be greatly appreciated.


I’m not familiar with raid, but from the report you posted it sounds like the kernel update is making changes to the way partitions are identified. The reported said he manually edited back the correct identity method.

When you install the /etc/fstab file will identify disk partitions like this:
As you quote

But according to the bug report, after update, if you were to look in /etc/fstab
The disc would be

What I find amazing is that no response has be added to that bug report.

Previous versions of SUSE used the older method /dev/sda1
in fstab
But now uses the by disk id method

It looks like it’s kinda messed up to me. You could edit /etc/fstab with a live cd. But that is a right pain.

Thanks for the reply caf4926.

Excuse my ignorance, I am currently running the live cd(Gnome) and can’t find my hard drives.

How do I find and mount my drives so I can attempt to edit the /etc/fstab.

So far I have opened a Gnome terminal and typed “su -” then “fdisk -l” but nothing comes up.

Also, assuming I can find the hard drive, what and where are the y2logs that are referred to in the bug report.

Never apologize for ignorance. Ignorance is OK. Persistance if OK. It’s the combination of both one should think about.
In fact it’s quite logical: the live-cd is supposed to leave your system untouched. But the tree is the same, so your harddisks should be visible in /dev. Normally they appear as sdXY where X is a letter and Y a number.
They are mounted like this:
mount /dev/sdXY /mnt
I don’t know enough about hardware RAID to tell you what it would be like.

When you type su, hit enter

the prompt ending will change from ~>
to: #

Now type:
fdisk -l
(that’s a letter lower case l as in linux)

To mount, use
eg: if device is sda1

mount /dev/sda1 /mnt

the /mnt = the location it will mount to

Now you can edit with

gnomesu gedit /mnt/etc/fstab

I think thats correct

Finally got it sorted, at least to the point I can boot it up and login. I don’t know if what I did is right, but it’s working. I also don’t know if anywhere else is affected.

For some reason with both the opensuse and ubuntu live cd, I couldn’t either “fdisk -l” or mount any of the partitions.

What I ended up doing was booting the dvd and using the recovery console to mount the / partition and edit the fstab.

So how does the bug reporting system work? Can I tag on to the existing report or do I create a new one?

So how does the bug reporting system work? Can I tag on to the existing report or do I create a new one?
You need to decide if the other report is identical to yours.
Reports at:
You should be able to login with your same user name and password as the forum (I think).

I just had the same boot up problem again where I get “could not find …”>:(

I checked out the /etc/fstab and there were no changes so I rebooted and it went straight through with no problems, so I don’t know what’s wrong.

I did notice that there is activity on only one drive when I save something which is not right, considering my RAID-1 setup.

It looks like my attempt to ditch Windows is going to be long and painful.:frowning:

If anyone has any suggestions?

I have no experience with RAID - sorry. Good luck!

Hopefully someone else will be able to offer some advice.

Thanks for your help so far caf4926.

Hopefully I can get it sorted.

-david- wrote:

> Thanks for your help so far caf4926.
> Hopefully I can get it sorted.

You can always find the right device to boot with by typing:

ls -l /dev/disk/*

This will show you all your options to designate hard disk -or partition-
(by-id, by-label, by-uuid, by-path) and the target device -or partition-
(/dev/sda1, /dev/sdb1…).

Just check the entries in /etc/fstab match the ones listed here.

As caf4926 already pointed out, the bug seems quite important because on
every kernel update, affected systems will not be able to boot unless
manually editing the corresponding files :frowning:




I have the same problem with my laptop, no raid though. After the kernel update it does not boot anymore. I changed the fstab back to use /dev/sda*, but that did not work either. Now it just says that it could not find /dev/sda* instead.

I also get earlier in the boot process several error messages:

FATAL Module pata_atiixp not found
FATAL Module ata_generic not found
FATAL Module atiixp not found
FATAL Module ide_pci_generic not found

However, when I do e.g. a find -name pata_atiixp*, it finds it under:


Anyone can give me a hind what else I can do to fix this?

Thanks for your help.



edited later

Just noticed when looking at the boot message that for the USB driver it says ‘Linux’

I have a second kernel version installed, not sure why. Anyhow, is it possible that it using that one?

How do I change that?

OK, I found it out myself. Here for the books what I did.

Running uname -a showed me indeed that the old kernel was used. I booted the system with the DVD into the rescue system and mounted the hard drive.

Then went into the boot directory and there were two symbolic links:


both linked to a version with the old kernel number. So I deleted those two links and create them new, linking to the new kernel version.

Booting the system just worked fine.