could not find /dev/disk/by-id/... opensuse 11.1

Hey everybody,

I started to install openSUSE 11.1 via USB-Stick on an IBM ThinkPad (without CD-Drive).
Pentium M
1,2 GHz
1GB Ram

Everything worked fine, until the System restarted during the Installation, at that moment it cannot find the partition at which openSUSE should be installed (/dev/sda1: system ; /dev/sda2: swap)!?

>Boot logging started on /dev/tty1(/dev/console) at Fri <…>
>Trying manual resume from /dev/disk/by-id/ata-HITACHI_<…>-part2
>resume device /dev/disk/by-id/ata-HITACHI_<…>-part2 not found (ignoring)
>Trying manual resume from /dev/disk/by-id/ata-HITACHI_<…>-part2
>resume device /dev/disk/by-id/ata-HITACHI_<…>-part2 not found (ignoring)
>Waiting for device /dev/disk/by-id/ata-HITACHI_<…>-part1 to appear: …
>Could not find /dev/disk/by-id/ata-HITACHI_<…>-part1
>Want me to fall back to /dev/disk/by-id/ata-HITACHI_<…>-part1? (Y/n)

No succes with yes or no => shell is started.

I also tried to Install the System with the bootoptions

hwprobe =-modules.pata

=> same problem!

I also set the root in the grub-menu from “/dev/disk/by-id/ata-HITACHI_<…>-part1” to “/dev/sda1”

=> same problem!

Need help!!! :frowning:

Thx Patrick

The CD ISO’s are hybrid for 11.2 and supposed to work from USB, but IIRC 11.1 procedure was different. Seems that most likely the initrd does not have the necessary drivers built into it to find the ATA Hitachi disk you have installed into.

When you boot from USB, can you make record of IDE drivers recognised? If you have a broken libata PATA driver like I did in then turning off pata_via with brokenmodule does make sense.

As for why brokenmodules didn’t change things, in 11.1 CD Install did not support the brokenmodules parameter. Switching to use brokenmodules post install was impossible, because mkinitrd used the modules currently running to chose what to build in.

I think with Live CD (from USB) you should be able to chroot into your installed system.

You need however a working kernel + initrd to copy in, inorder to run mkinitrd (I think) and generate the device support you need.

A work round I used was to build kernel myself, and compile in (non-broken) driver, with broken driver compiled out. I wouldn’t recommend this though, as kernel configuration is much trickier than it used to be to get right from scratch.

You might be lucky, and able to add modules you need to generate initrd which can mount root, and access swap running live.

If you have another machine, than can mount DVD iso, and export mounted directory via NFS, then I’d be very sure a Net install would support brokenmodule boot argument.

Did you change this on on place only or on all places where the /dev/disk/by-id construct is found in menu.lst? Of course changing to /dev/sda2 where -part2 is mentioned.