Could need some help with Java game TripleA

The game starts up fine but if I try to load a map it givers out this error message:

triplea.engine.version.bin:1.7.0.3
Exception in thread "Triplea start thread" java.lang.ExceptionInInitializerError
    at games.strategy.engine.message.DummyMessenger.<init>(DummyMessenger.java:44)
    at games.strategy.engine.framework.startup.launcher.LocalLauncher.launchInNewThread(LocalLauncher.java:59)
    at games.strategy.engine.framework.startup.launcher.AbstractLauncher$1.run(AbstractLauncher.java:57)
    at java.lang.Thread.run(Thread.java:722)
Caused by: java.lang.IllegalStateException: java.net.UnknownHostException: DDAchtung: DDAchtung: Name or service not known
    at games.strategy.net.Node.<clinit>(Node.java:50)
    ... 4 more
Caused by: java.net.UnknownHostException: DDAchtung: DDAchtung: Name or service not known
    at java.net.InetAddress.getLocalHost(InetAddress.java:1466)
    at games.strategy.net.Node.<clinit>(Node.java:47)
    ... 4 more
Caused by: java.net.UnknownHostException: DDAchtung: Name or service not known
    at java.net.Inet6AddressImpl.lookupAllHostAddr(Native Method)
    at java.net.InetAddress$1.lookupAllHostAddr(InetAddress.java:894)
    at java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1286)
    at java.net.InetAddress.getLocalHost(InetAddress.java:1462)
    ... 5 more

Thanks

Are you connected to internet? why are you getting “unknown” host?

I don’t know why I get ‘unknown host’, and I get this on two computers both running 12.2 (different ‘host names’ of course).
Yes, I’m connected to the internet, however, the example given is from trying to start a local game.

Any clues?

Thanks for replying:)

The unknown host message AFAICT has nothing to do with internet connection. What could be the culprit here is that the game requires the Oracle Java runtime instead of openJDK.

Another one: how do you start the program?

I actually tried the Oracle Java, and I got the same result. The program comes as a zip package, which I extract onto my home directory. There is a bash file with it to start the game:

#!/bin/bash

if ! java -version > /dev/null 2>&1
then
echo "Could not find Java."
echo "You must have Java installed and in your path."
exit
fi

relativePathToGame=`dirname $0`
cd "$relativePathToGame"


java -Xmx896m -cp bin/patch.jar:bin/triplea.jar games.strategy.engine.framework.GameRunner

The program starts up fine and one sees the menu/option list; it is when one has selected a scenario/map and click on ‘Start’ that it crash.

Thanks:)