Corrupt Kwallet

Some how my Kde wallet seems to have got corrupted.
When I get the pop up window asking me to enter my password I get an error message

 Error opening the wallet '**kdewallet'.** Please try again.
(Error code -9: Read error - possible incorrect password.) 

The password I am entering is definitely correct.
I have also tried to reset it by following the advice give on this thread https://forums.opensuse.org/showthread.php/496238-How-can-I-reset-KDE-Wallet-password-if-I-can-t-remember-it but that doesn’t work either

 
warren@linux-hhz5:~> su
Password: 
linux-hhz5:/home/warren # mv ~/.kde4/share/apps/kwallet ~/.kde4/share/apps/kwallet.org
mv: cannot stat ‘/root/.kde4/share/apps/kwallet’: No such file or directory
linux-hhz5:/home/warren # mv ~/.kde4/share/apps/kwallet ~/.kde4/share/apps/kwallet.org
mv: cannot stat ‘/root/.kde4/share/apps/kwallet’: No such file or directory
linux-hhz5:/home/warren # cd ../../
linux-hhz5:/ # mv ~/.kde4/share/apps/kwallet ~/.kde4/share/apps/kwallet.org
mv: cannot stat ‘/root/.kde4/share/apps/kwallet’: No such file or directory
linux-hhz5:/ # 

You seem to be logged in as root. Perhaps that is the cause of your problems.

To add to my previous comment:

Login as yourself, as a non-root user. But login to “Icewm”, or login to a virtual console (via CTRL-ALT-F2), so that you are not logged into kde while doing this.

Then try deleting your old kwallet so that you can recreate it.

Thanks Nrickert deleting kwallet from outside the kde platform done the trick.

And as an additional advice, please try to understand a bit more about what happens when you login as root.

To begin with, you should not use

su

but

su -l

or shorter for the same

su -

read

man su

Then, when you are loged in as root, you are not loged in as another user (sounds logical), thus when you use ~/ as short for “the home directory of the loged in user” that expression is NOT short for /home/<username>/, but it is short for /root/ (the home directory of root) That means that you are now tinkering around in a place you should not change anything. See how easy it is to do stupid things when being the Superuser?

I installed Kontact on an ex-Windows XP machine running Xfce for someone mainly because it imported MS Outlook folders very easily. He has been getting the same error message as in the first post. However, I have now found out that, prior to this, he was getting a pop-up inviting him to Migrate his passwords to kwallet (even though they were already in kwallet). Every time he accepted this suggestion, kwallet became corrupted and I have had to delete the corrupted wallet and create a fresh one. I have now told him to ignore the pop-up.

Has anyone else had a similar experience?