Core i5 running slow (like AMD Cool'n'Quiet)

I’ve just gutted my computer and replaced an old Athlon 64 3500+ with a Core i5 750 while keeping the same drives, graphics and case. The Athlon used to run at 1GHz, cranking up to the full 2.2GHz when it needed to. The Core i5 is supposed to run at ~2.8GHz with all cores running or up to ~3.2GHz with one or two cores active. For some reason mine seems to run at 1.2GHz unless it needs to crank everything up, at which point it goes to 2.66GHz (base clock speed with no “turbo buckets”).

I’ve tried upgrading to the latest Kernel-desktop package for 11.2 from the OBS (2.6.34-rc4) in case this bug meant that support hadn’t landed properly until .33 (11.2 only runs kernel .31) but it hasn’t made a difference.

I’ve changed several of the BIOS settings from “auto” to “enabled” to make sure that the stepping is enabled, but it doesn’t affect anything. I’ve tried using “turbostat” and just got a load of numbers that say very little (other than that it is normally running at 1.2GHz and it is using various states). dmesg only seems to contain the following that relates to C states:

    1.444543] Monitor-Mwait will be used to enter C-1 state
    1.444560] Monitor-Mwait will be used to enter C-2 state
    1.444576] Monitor-Mwait will be used to enter C-3 state

and powertop just gives me:

Cn                Avg residency       P-states (frequencies)
C0 (cpu running)        ( 1.4%)         2.67 Ghz     6.5%
polling           0.0ms ( 0.0%)         2.67 Ghz     0.0%
C1 mwait          0.1ms ( 0.1%)         2.53 Ghz     0.0%
C2 mwait         16.4ms (79.7%)         2.40 Ghz     0.0%
C3 mwait         23.3ms (18.9%)         1197 Mhz    93.5%

and some info about wakeups.

So, is this expected behaviour for some reason (I wouldn’t think so) or did I do something wrong and my OS still thinks it should be running the CPU in “Cool’n’Quiet” mode rather than Core i# “turbo bucket” stepping mode? If it’s the latter, how do I fix it?


Hmmmm, odd. Using i7z it looks like it might be turboing correctly when needed, but I’m not sure. Some of the numbers look like it isn’t sleeping as much as I’d expect.

Idle (nothing but Thunderbird, Conky, Compiz, Chromium and a Console) use has multipliers around 9-12 with C0 percentages in single figures on all cores. Running “cat /dev/urandom > /dev/null” bumps one core’s C0 percentage to 100 and its multiplier to 24 in i7z, but the other cores also get a frequency boost and still have a few percent on C0, plus Conky reports 1.2GHz. Running “cat /dev/urandom > /dev/null” in three consoles gives me 4 cores with a 21x multiplier in i7z and Conky reporting 2.66GHz.

Is all of that right? Is my Core i5 actually running correctly and Conky was just not reporting it right? It doesn’t quite seem to be what I expected from the i7z app (I thought it should completely sleep cores and avoid odd little percentages on each), but it does look like i7z is reporting the turbo boosts.