Copying to NTFS Partition

I usually have to use Konquerer super user mode to copy files to an NTFS partition. It would be so much easier if I could copy to said partitions without having to log into root.

Is there a way?

if you have ntfs-3g installed & configured,i believe you can do this,not that i know how,don’t use ntfs filesystem or anything windowish. Only windows in my house are the ones i look out of lol!


The ntfs-3g driver is installed by default. While it does allow you read/write ntfs access, you still need to be logged in as root to be able to write to an ntfs partition.

I have some similar problem before a few moths ago. I’m changed some fstab options, like umask. Go to YaST -> System -> Partitioner, select the ntfs disk, and click to Edit. Here go to fstab options, and set the Arbitrary Option Value to


(Of course if you have something different here, back it up to a text file, or something.)

Maybe it helps

I changed this:


To this:


I then tried to paste something but write access wasn’t allowed. Within the folder structure of the partition, the permissions options are still greyed out.

I just noticed something interesting, SuSE is setting the values back to what they were before I made the changes. It appears that I am unable to make the changes stick.

search yast2 for ntfs-config i believe it is the gui for ntfs and it will allow you to setup read-write to your ntfs partitions really easliy

It might help to read all the options. Here’s some background:
HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10, 11

This is what should ordinarily be used for internal drives:

/dev/sdax    /path_to/mount_point    ntfs-3g    defaults    0 0

Of course, change sdax to match your situation

But if you have an external usb drive you use something different, like read this bit:
Automounting external (USB) NTFS drives in read-write mode

Hi all,
I am new with Suse.
But what I want to ask is: how can I open from terminal the fstab file???
I have tried:
sudo gedit /etc/fstab but I have to put an other command.
How can i do that?

gnomesu gedit

It would be so much easier if I could copy to said partitions without having to log into root.

Try “ntfs-config”. Its a little tool which allows you to easily give ntfs partions write permissions. Its available in the repos.

Note: If “Enable write support” is already checked just uncheck it and check again. It took me hours to figure it out.

It will, may be a dumb answer,but i face this problem before.I use Dolphin, and every thing went perfect. As don’t forget to use the ram88 method. after that you can do whatever you want, just use dolphin, not Konquerer.Konquerer has some issues with permissions for ntfs-3g.
Link to my thread for more details:
Link to thread

Hope this can help.

tnx. That’s worked. I run yast-software management and find “ntfs-config”.