Copying Text Into A Virtual Machine

I am having an issue that I am guessing is something I am doing wrong, but I can’t figure it out. I am trying to simply copy text from one virtual machine into another. I am using VMWare Workstation running on opensuse 15.4 , and the guest that is receiving the text is also opensuse 15.4. If the guest is Windows, the paste works just fine. Now if I copy text out of a Windows VM, I can paste it into my host OS just fine. What am I missing or doing wrong?

Make sure you’ve got the guest tools installed in the guest.


This is what’s installed in my 15.5 VMware guest (copied and pasted from the guest to this post, in Chrome on my host). :slight_smile:

For me, I had to install spice-vdagent on both machines and have it running on both machines.

1 Like

First off, apparently I must have updated my VM because I am also running 15.5…
With that, I have this:


That may be an alternative way of doing it - I don’t have spice-vdagent installed on either system here.

In the VM configuration, also make sure you have copy/paste enabled in the “Guest isolation” configuration:

It would appear that I do have those options enabled, and I can confirm this because if I run any desktop but KDE, the pasting works just fine. With that, I am guessing this is some type of KDE bug somehow.

Do you use KDE with Wayland or X11?

Initially I noticed the problem when using Wayland so I subsequently switched to X11 where the problem still exists.

One of the challenges I’ve seen is that there are different copy/paste buffers that might be used - so it may just be a matter of switching how you’re pasting. I don’t use KDE myself, so I can’t advise as to the different options, but I have seen in other remote desktop environments that I’ve used that where CTRL+V doesn’t work, sometimes a middle click does (for example).

I remember reading up some about just what you were talking about so I have been using the applications menu options (plus tried keystroke shortcuts to verify the same results) to perform the pasting action. It must be something with KDE running as a guest because all other DE environments don’t exhibit this issue.

1 Like