Copying large file to usb fails with default options

I recently attempted to copy a 1.4GB file to a usb key. The transfer was unsuccessful. Transfer speeds dropped to about 1K per second after the first 140MB. The only solution which worked was to manually mount the usb partition with ‘mount -o async /dev/sdb1 /mnt’.

Is this a known issue? After mounting with the async option the transfer finished in a normal amount of time. Before using the async option the usb drive would become unusable. Are there any other options?

davidgurvich wrote:
> I recently attempted to copy a 1.4GB file to a usb key. The transfer
> was unsuccessful. Transfer speeds dropped to about 1K per second after
> the first 140MB. The only solution which worked was to manually mount
> the usb partition with ‘mount -o async /dev/sdb1 /mnt’.

Please supply relevant kernel error messages.

> Is this a known issue?

Known issues are listed in our bugzilla.

> After mounting with the async option the
> transfer finished in a normal amount of time. Before using the async
> option the usb drive would become unusable. Are there any other
> options?

No, those two are basically it. Note that with async you really want to
unmount or at least sync the device before unplugging it. You also won’t
get aroung waiting for the data to be actually written when you do that
even if it appears to be on the file system immediately.

Kind regards,
Andreas Stieger