copying files to windows share not possible

Hi there,

after installing LEAP 15.2 I noticed that I couldn’t access a windows share on an old multimedia device using smb. After inserting the line

client min protocol = NT1

into /etc/samba/smb.conf I could again open the share, create or delete a directory and view a file. But when I upload a file there is always a message “not enough disk space” - although the disk is nearly empty.
Switching back to LEAP 15.1 uploading works.

I couldn’t find anything appropriate in the docs as well as in the forums.
Any ideas what might be wrong?

Thanks for help

Know issue with smbd 4.11 - seems to still be an issue with 4.12.
They plan to remove all SMB1 from samba soon.

Quoting the internet “Windows XP SMB1 is over 15 years old and should have been retired at Windows 7”

Many companies have old XP machines running equipment that there no way to run on newer machines as the code contains 16 bit drivers and XP was the last version that supported those 16 bit apps natively. - You don’t turn off a $5,000,000 machine because the controller only works with Windows XP and the company that made it is no longer in business.

# smbd --version
Version 4.11.5-git.161.74bc5e6ec8elp152.2.12-SUSE-oS15.0-x86_64

The edit timed out

What I have done to get files to old Windows XP computers is to create a copy of the directory I need to put files on in my Linux box and I put ssh & rsync (I installed cygwin on the xp boxes to get them) and I “rsync -av --delete /local-directory/ user@ip-of-windows-xp:/path-to-directory” to that directory on the windows box.

cygwin is free and rsync works great.

Many thanks for your quick suggestion. With an an old computer I would follow it. But this nasty old device came without an easy way to get administrative rights. So I don’t see the possibility to install any necessary software on it.

You can use a barts pe (you are always administrator in barts) and install cygwin to the xp 's C: drive (probably E: in barts)