copying files slow

Hello,

I am running OpenSuse 11.1 with KDE 4.2 on an Corde2Duo 2 x 1.66.

Copying files on the same partition to another folder is quite slow. The speed is about 15 Mb/s, even if I use the bash. So KDE can’t be the problem. Filesystem is ext3.

hdparm -tT /dev/sda retrieves

/dev/sda1:
Timing cached reads: 1008 MB in 2.00 seconds = 503.63 MB/sec
Timing buffered disk reads: 194 MB in 3.03 seconds = 64.12 MB/sec

and hdparm -i /dev/sda

/dev/sda:

Model=SAMSUNG HM160HC , FwRev=LQ100-10, SerialNo=S12TJD0PB17708
Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
RawCHS=16383/16/63, TrkSize=34902, SectSize=554, ECCbytes=4
BuffType=DualPortCache, BuffSize=8192kB, MaxMultSect=16, MultSect=?16?
CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=312581808
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5
AdvancedPM=yes: disabled (255) WriteCache=enabled
Drive conforms to: ATA/ATAPI-7 T13 1532D revision 0: ATA/ATAPI-1,2,3,4,5,6,7

  • signifies the current active mode

Is there a chance to speedup the system?

greetings,
Stefan

mount your filesystems with the noatime option in /etc/fstab

Also, if you are copying files downloaded from torrents and your client doesn’t support file preallocation or it’s not enabled, your files will be fragmented so copying to other places will be slower

Your settings look good though