copy, move, rename long file names across local network, not working

When I tried to copy, move, rename files or directories with long names from one openSuSE system to another or a server on my local, ‘home’ network, kde, konqueror and ‘notification’ would just kinda sit there…
Did not finish, fail, error or time out, just sit there as if it were working…

First, I blamed kde as I’ve not like ‘them’ since ‘they’ decided to adopt dolphin while it was less than beta, as the default file manager…

Then I thought it might be the ‘dot’s’ in the middle of the filename as in a version number title, but is not a consistent issue, so that’s not it
Hmm.
I’ve also found that some if not all files with ‘double spaces’ in the filename can and do fail at times, but not every time, so that wasn’t it.

Anyways, it was Not kde, the coders at kde, konqueror or even the notification applet (was looking to blame something… : o ). No it was me…

for example, here is a file name that worked and the original version that did not:

Worked with copy, move, rename:
Linux From Scratch Version 6.1.1 Gerard Beekmans.pdf

Did Not work for any of above actions:
Linux From Scratch
Version 6.1.1
Gerard Beekmans.pdf

See the difference?
When I originally copied the name for the title of the document, the carriage returns (eol, ‘enters’ etc) were not replaced as I thought always were… Not sure why that is, as I rarely have this problem and it’s not obvious in the filename when you’re done pasting.

Anyways… that’s it, just in case someone else is having this same head scratching issue…

Landis.

How are you copying? Using the command line? The shell breaks into arguments at spaces, so you have to quote filenames with spaces (and other special characters).

[edit… could not, too long a time]
p.s., I don’t know how to tell the filename has ‘returns’ in it using the file manager, properties or ‘rename’ function. I have 2 ways. One: delete and reapply the spaces in filename using rename or Two: past name into a text editor or web page ‘form’… just sayin’
[/edit]

A couple of ways to avoid the problem:

Use a GUI manager to copy using drag and drop. It will take care of special characters.

Use a command line invocation that will not be affected by special characters. Something like this is safe:

cp /from/here/* /to/there

because the special characters do not explicitly appear in the command line. (But filenames starting with dot will be missed.)

There are also advanced ways involving cpio, find, etc.

I am using konqueror, a GUI
And as I said, it apparently, usually takes care of the ‘special characters’, but obviously not…
I was only letting others who have had this issue, like me and they don’t know what is wrong what I found was a possibility…

just saying, that’s all

Спасибо,
Landis.

Well maybe you found a konqueror bug that should be reported.

I was also having this same issue when i found this handy tool.

Path Too Long | Filename too long | Filename is too long | Path too long utility

many thanks

i had this problem and this fixed for me

keep up good posts

Long Path Tool helped me in this situation. http://PathTooDeep.com

After days of searching I finally found solution for unlocking, managing and renaming
long named files. Get your problem solved from Long Path Tool: Path Too Long | Filename too long | Filename is too long | Path too long utility

Hey! guys, I had encountered the same problems with you. I ain’t using Linux or other OS except for Windows (2000, XP, Vista, 7 preferably).

I used “Long Path Tool” software to ease my problem. It can delete long path files, broken links of shared folders.
Actually, here’s the problems which most of us (i guess) encountered :
"

  • Path too long
  • Error cannot delete file: cannot read from source file or disk
  • Cannot delete file
    : Access is denied - There has been a sharing violation.
  • Cannot delete file or folder The file name you specified is not valid or too long. Specify a different file name.
  • The source or destination file may be in use.
  • The file is in use by another program or user.
  • Error Deleting File or Folder
  • Make sure the disk is not full or write-protected and that the file is not currently in use.
  • Error Copying File or Folder.
  • Cannot remove folder.
  • The filename or extension is too long.
  • Path too deep.
  • Destination Path Too Long.
  • Could not find this item.
  • Filename is not valid.
  • The file could not be accessed.
  • Windows Delete Path Too Long
  • Source Path Too Long Delete
  • The path you entered, is too long. Enter a shorter path.
  • File Name could not be found. Check the spelling of the filename, and verify that the file location is correct. "
  • These are problems are being solved by “Long Path Tool”. I am sharing you about this tool, for I know that it could really help you :wink: