Convoluted wireless process

Finally managed to get wireless to work, but this is what I had to do:

KNetworkManager does not start at all when I run Alt-F2 and try typing KNetworkManager. It seems to be there but nothing happens when I type it. YAST configuration for wireless fails to connect despite setting up SSID, key etc.

So I tried ifconfig, could see that eth1 is the wireless card. Then I used iwconfig to set the ssid, key etc. Then used dhclient to make it accept a IP address. That worked fine.

Despite this I could not use the internet because I think the system was using eth0 which is wired one connecting to same router using DHCP and not eth1 to go to the net. This was shown by a line in the output of ip route which said default via eth0.

Finally I had to ifconfig eth0 down, use ip route add default which then used eth1 because now eth0 is down…

Needless to say, this has to be repeated at each login

Any advise on automating this during login and being able to choose wired (eth0) or wireless (eth1) depending on what is avaiable, would be great…Of course, any easier method to do this also would be nice…


YaST - Network devices - Network settings,select ethernet device,edit, set it to on cable connect.Should sort this out


Thanks for the tip…actually nothing happens when I click on YAST Network Devices, even as root and same goes for NetWorkManager. When I run KNetworkManager, I notice there is a globe icon on the taskbar bottom right but it says KNetworkManager is not running, not able to see where to make it run.

Actually would not mind if I do this whole thing outside KDE in text mode, that way get to learn few things. However, I would like to make it a script to run automatically at log-in

> nothing happens when I click on YAST Network Devices, even as root
> and same goes for NetWorkManager.

that sounds like you are logging into KDE (or maybe gnome) as root…

NEVER do that, instead always log in as a user and then become root
for specific tasks…using YaST as root is the easiest as it ask for
the root password when you launch it…

learn all about it at:


No sir, not logging as root. It is KDE (4.2.2 latest) by the way. YASt does ask for root password when entering.

Sorry dont know what happened, have been trying this for several days now. Now KNetworkManager works, ie can connect to wireless without manual process. I still need to start it manually but that is not a big deal