ConvertX with openSUSE 11.0 on Lenovo 3000 N200: How To?

Hello everyone,
now i need your help…

I’ve got the Plextor ConvertX PX-TV402U and
the System mentioned in the title (64-Bit).
I’ve tried every instruction i found, to get
this box working, but my system refuses to
load the driver!

First i tried it the way they discribed it here.
But when i compile the driver (wis-go7007-linux-0.9.8),
i got these errors:

***** Using kernel source in /usr/src/linux- *****

make modules -C /usr/src/linux- M=/home/zwenny/wis-go7007-linux-0.9.8/kernel
make[1]: Entering directory `/usr/src/linux-'
make -C /usr/src/linux- O=/usr/src/linux- modules
  CC [M]  /home/zwenny/wis-go7007-linux-0.9.8/kernel/go7007-v4l2.o
/home/zwenny/wis-go7007-linux-0.9.8/kernel/go7007-v4l2.c: In function ‘go7007_do_ioctl’:
/home/zwenny/wis-go7007-linux-0.9.8/kernel/go7007-v4l2.c:942: error: ‘AUDC_SET_INPUT’ undeclared (first use in this function)
/home/zwenny/wis-go7007-linux-0.9.8/kernel/go7007-v4l2.c:942: error: (Each undeclared identifier is reported only once
/home/zwenny/wis-go7007-linux-0.9.8/kernel/go7007-v4l2.c:942: error: for each function it appears in.)
make[4]: *** [/home/zwenny/wis-go7007-linux-0.9.8/kernel/go7007-v4l2.o] Fehler 1
make[3]: *** [_module_/home/zwenny/wis-go7007-linux-0.9.8/kernel] Fehler 2
make[2]: *** [sub-make] Fehler 2
make[1]: *** [all] Fehler 2
make[1]: Leaving directory `/usr/src/linux-'
make: *** [all] Fehler 2

So i tried another driver version (wis-go7007-linux-0.9.8-2)
from here.
The Compilation went through after i’ve installed
“ncurses-devel” like it is suggested here.
But the driver doesn’t load!
When i plug in the device, it is recognized
and listed in the table of



dmesg | grep go7007


grep go7007 /sys/class/video4linux/video*/name

return nothing.

Has anyone of you an idea, what’s the problem?

Okay, now i figured it out.
The compiled driver
(wis-go7007-linux-0.9.8-2) works!
I just have to type:

mount -t usbfs none /proc/bus/usb

before i plug in the device.
Then the driver will be loaded
and i’am able to watch the output
with VLC :slight_smile:
(video device: /dev/video1
audio device: /dev/dsp1)

I hope this helps the other
users, have been unsuccessful
getting this wonderful Box
working :wink:

mount -t usbfs none /proc/bus/usb

I found out, that this command causes my system being unable to access my webcam any more.
So i tried a little and it’s better just to:

mount /proc/bus/usb

again before plugging in the device.

For me it works! :slight_smile: