Continuous need for updating Flash player in Myspace

Hello dear Suse users.

With all my creativity and search in different forums I could not solve this annoying problem:

Whenever I open Myspace, the player does not work, instead it tells me to update my Flash player. I went to the Adobe website, downloaded the tar.gz version of flash player, unpacked it into my Downloads folder and installed it into /usr/lib/firefox (it then went into the plugins folder).
Sometimes it then works. BUT after I close firefox or shut down the computer the same problem starts again. And then I can update it as often as I feel for, it won’t work. After a few days, I try again, and the whole game restarts.

Youtube works fine.

I would be so glad, if anybody could give me the missing hint.
Best regards,

I tried the rpm. version, but this does not work at all.

Don’t use myspace, but had a quick look.
On SLED11 with shockwave Flash 10.0r22 everything works.
It should be on the 11.x update site.
After installation, check that firefox has it listed as a plugin.

Flash, k3b, Amarok - Install Guide - openSUSE Forums

very often, when a web site tells you to update your flash player that
notice is from a script which LIES…actually, what is going on is
there is something about your browsers java-script which isn’t working
with the site…

AMAZINGLY this very often happens when contacting a Microsoft-IIS/6.0
server (like MySpaces)…amazing that when Linux connects to M$ there
are strange problems, huh??

NOTE: you might also see notices to update your Java…my experience
is that most likely that is ALSO a lie…

try this: install NoScript on your firefox…and, set it to not allow
any java-scripts…THEN go to my space and specifically allow the
myspace java-script…

MAYBE that will solve it for you…maybe not…

another thing you might try is to install the add-on “Default User
Agent” and switch to pretending you are using IE and try myspace that

DO not leave it always saying it is IE…there is no need to boost m$
apparent presence on the net…

have fun…


Thank you for your replies!

Nothing really worked, BUT… I installed Adobe Flash out of yast instead of .tar.gz - and for some reasons it now works.

Explain the world to me…

I installed Adobe Flash out of yast instead of .tar.gz - and for some reasons it now works
Of course it will. We did link you to a Yast Install method

I now have the same issue with Suse 12.1 and FlashPlayer flash-plugin-
I installed with the rpm command and then yast. Nothing works.


Tagging on to an old thread like this is a poor approach.
Try presenting a more complete summary that is logical and coherent.