continuous high fan speed


installed 11.2 x64 on my new Dell Studio 15 laptop. Everything works fine and out of the box (unlike other reports made on this forum), except the ATI 3d driver of course.
What i dislike is the continuous high fan speed, which is much louder than on Win7 (dualboot). The temp is not higher than on windows, so it shouldn’t be this loud. Is there any way to modify the fan settings? I can’t hear myself think with this noise!


zara999 wrote:
> Is there any way to modify the fan settings?

the results of the following search indicates there are things you
can do and/or try:

and, you can wiggle the search string some if those 70+ are not
helpful…by wiggle i mean, maybe remove “Dell” to open it up to more

or remove the site specifier and replace it with ‘linux’ like in this

but then you get like almost 5 million hints…whereas the one with
“Dell” and just in these forums give a more manageable 73…

read several of the 70+ and come back with how you get on, or questions…


Are you running FF or Chrome at the mean time.
What this command reports.


I am not able to perform this now. However, i’ve tried this before with firefox, Xorg or other apps not reaching values over 30-40%. The conputer temp (ACPI or BIOS thermal) is normal at 40-50 degrees (same as under Win7).

Thanks for the tips. However, i’ve tried those with no result yet.

zara999 wrote:
> @palladium
> Thanks for the tips. However, i’ve tried those with no result yet.

keep looking, it is just a matter of figuring out why the automatic
fan speed controller thinks the CPU (or something) needs full speed,
full time fan…

i know i’ve seen that discussed here for a variety of hardware…check
your bios settings and kernel parameters…


Hey zara999,
I also have a Dell Studio 15. At the beginning I also had trouble with the speed of the fan, until I got to install the ATI propietary driver.
I had to do it the hard way, but it finally worked.

Hope it helps.

An update:

after searching the net, mostly on fora like ubuntuforums, i’ve found that this problem most likely has to do with the supplied BIOS of my Dell laptop. The crappy BIOS i have to say. Due to this BIOS the fan speed cannot be controlled by Linux, nor by programs like Dellfand of i8kfan.

Seems i have to stick to Win7 :frowning:

If one has a solution (besides getting another laptop)? Much appreciated!

zara999 wrote:
> If one has a solution (besides getting another laptop)? Much
> appreciated!

the best way to make sure you get hardware which is good with Linux is
to buy hardware with Linux installed…Dell sells laptops with Linux
installed (and, those may NOT run either Redmond nor Apple well)

please update the Hardware Compatibility List at

see how to ‘easily’ on under “How to add
hardware information to the list?”

note: imho there is no easy way


tried another time, being stubborn and all…

installed the 11.2 x86 version and with the proprietary drivers (which auto-installed by the way) it all worked! No more noise when using Suse!

Seems that the fan of my Ati card isn’t controlled properly by the opensource driver. This seems to be the case with all more recent Ati cards. For example, the new Ubuntu release uses a higher version of Xorg, which has no proper proprietary driver yet. And thus results in a crazy spinning fan…

i’m you persisted!!

DenverD (Linux Counter 282315)
posted via NNTP w/TBird | KDE 3.5.7 | openSUSE 10.3 SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio