Continuous hard drive access and freezing GUI

I recently installed Leap 42.1 a desktop that was running OpenSuse 13.2. I did this install because the OpenSuse 13.2 drive would not boot to the GUI. I thought installing to the latest version would alleviate my problem of continuous disk accesses to the point where the machine was frozen. While the Leap 42.1 is not quite at the stage where it is completely frozen, it continues to have the similar affects of the continuous drive accesses and temporary frozen desktop.

I am running KDE.
I have built it on an ASUS A5A90-V EVO. AMD CPU, 16 GB memory. I am not going to rule out a hardware issue as I’ve had this machine for some time. I am getting the following in the screen directly before it boots into Leap:

ata7.01: failed to set xfernone (err_mask=0x1)
ata2.00: exception Emask 0x0 SAct 0x200 SErr 0x0 action 0x0
ata2.00: irq_stat 0x4000008
ata2.00: cmd 60/80:48:80:08:00/01:00:00:00:00/40 tag 9 ncq 196600 in
res 41/40:80:61:09:00/00:01:00:00:00/00 Emask 0x409 (media error) (F)
ata2.00: staus {DRDY ERR }
ata2.00: error: { UNC }
blk_update_request: I/O error, dev sdb, sector 2401

I believe that indicates a hard drive error - but I’m not sure. I really am not sure what I should investigate to get to the root issue. I have seen comments here and there about video drivers possibly causing this.

Another note that I have tried three different hard drives, and sata cables all continue to have the same issue.

Any help would be greatly appreciated.

Use smartctl to see hard drive errors

note man smartctl for details

Does sound like a drive failing