Contents of ntfs drive not completly displayed?

i have installed opensuse 11 64 bit on inspiron laptop(came with pre installed VISTA) as dual boot , unfortunately in windows i have only one NTFS drive(i cant resize it further down) which has OS (C:),
now i try to access this drive in Opensuse kde4/gnome, though it shows the drive, it shows only partial contents i cant find my directories like say user desktop etc:(… and i coped few files in C: but they are not visible in vista>:(.
i wonder if Vista has some security feature that that hides or … :(?
how to get rid of this restriction.

thanks in advance

This can happen if the locale for the drive is not included in the instructions for mounting the drive that are contained in /etc/fstab.
Is it possible that the drive was constructed or sold or formatted in a language/country different from the one that pertains to Suse – or something like that? If it is possible then examine the file /etc/fstab and post here the line from fstab that mounts the ntfs partition.

I remember somewhat similar problem with NTFS,
wher Windows XP was installed - some files were
seen from openSUSE, some not.
And I did not find a way to solve this problem.

Now I don’t have anything now in NTFS partition on my laptop ,
which came preistalled with Vista (ugh!) too.
Vista did not wanted to resize partition properly with built in tool
(don’t remember its name), but I was able to do it via Yast.
So maybe if you have this resize issue too you may try using another partitioner.

Dear friends thank you very much for reply
here is mount option in fstab for C drive
/dev/disk/by-id/scsi-SATA_WDC_WD2500BEVS-_WD-WXC608A69522-part2 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0

This is the language option: “locale=en_US.UTF-8”. Looks like the default has been used. Here is a quote from the developers of ntfs-3g, thge driver which mounts NTFS partitions:

If the locale environment is not setup correctly before mount then glibc can’t convert some filenames, so they are not visible

You should change the locale option to the value that was used when the partition was created. You can reveal the locales available in your Suse package by executing this command in a console:

locale -a

thank you for reply…
so how can i get rid of this? is there any way that i can know locale used at partioning … mine is a dell laptop bought in india

I don’t know the locale definition for India. Have a look into the response you get to the command “locale -a”.