Constant "Updates are being installed"

When Software Updates runs (set to run daily), right side of screen fills with “Updates are being installed” alert boxes. Try canceling them but they keep appearing.

New install of 11.1 over the weekend on a Dell GX620.


Do you know if any updates have actually been installed?

Close the software updater with right click (you can leave it to load at startup if you want)

Now open a terminal and go su, then type

zypper ref


zypper up

That should update you. Of course we don’t know what repo’s you might have added (zypper lr)
There is a recent kernel update which will require a reboot.

Hi, I have same problem, when I type zypper ref, it says

Repository '20090309-143918' is up to date.
Repository '20090309-185936' is up to date.
Repository 'openSUSE-11.1-Non-Oss' is up to date.
Repository 'openSUSE-11.1-Oss' is up to date.
Repository 'openSUSE-11.1-Source' is up to date.
Repository 'openSUSE-11.1-Update' is up to date.
All repositories have been refreshed.

I think that’ll mean my openSUSE is up to date. Anyway, don’t you have the same issue? I’m running x64. One more thing, the updater did completed the update, but after that I think it’s trying to find the update again but since it’s already updated, it somehow looping. Sorry for my bad English.

Hi -

Help! Opensuse noob here. I have this problem too. Just installed 11.1 gnome. Have set auto update. It looks like it updates and is finished but a notification panel in lower right says “updates are being installed” and “updates are being automatically installed on your computer” and then 2 dialog boxes “cancel update” and do not show this again" The panels stack about 6 high. It is a constant loop and in the sys tray app (keeps flashing)

Right click on sys tray yields “about”

Left click returns “updating system”

Can’t break it. I had to reboot

Any thoughts on the issue? I suppose I should disable auto update and see what happens next time but rebooting is sort of an annoying fix.

zypper ref - refreshes the repo’s -when it says they are up to date, it means the info in them is.

do: zypper lu - to show updates available

or zypper up - to just update

right click on the updater applet should offer more than ‘about’

Many thanks for the tip.

I’ve experienced the same issue on each of a SUSE 11.1 machine and a SLED 11 machine.
In both cases it seems due to having’s repository included for VLC Media Player. Manual update for that fixes the problem (I think - we’ll see).

I upgraded from Suse 11.0 to 11.1 and then the same issues started to occur with the updates. I’ve done these suggestions from the lower thread

open YaST, give root password, then

–go Software > Software Repositories and

– check that you have ONLY four repos enabled, the four listed here:
NEW Users - Suse-11.1 Pre-installation – PLEASE READ - Page 2 - openSUSE Forums

–disable all others (including the CD/DVD), then

–go Software > Online Update, wait for it to finish updating itself,
then when you see the list of updates (if any) click accept, then.

That seemed to fix it until today. Now I’ve done what caf4926 has said. Will see if it fixes it.

Here is the other thread with the same issues

update popups becoming really annoying - openSUSE Forums