Constant Hard Drive Activity

I have used Linux for many years, and OpenSuse on my desktop for the past few years. OpenSuse has had very few problems, which were easy to solve. I just upgraded from Leap 42.2 to 42.3 (Gnome) including all updates. Everything worked fine until three days ago when everything slowed down and the hard drive activity light stayed on constantly. I did several reboots, wich went as expected, but as soon as the desktop was displayed, the hard drive light came on constantly, and the computer is slow. Other than slow, the applications, and hardware, all seems to work correctly. I tried HTOP, but I could not see a clear pattern. Nothing was consistently hogging the resources. I ran the system monitor, and the CPU loads were erratic on all six cores. The load would max on one core and then go to zero, and one or more other cores would max out. This with only the system monitor software running. Interestingly, I did not see any significant amount of data transfers on the network, so it is not a data communication issue. Frustrated, I finally ran “DBAN” on the hard drive, doing a DOD data wipe, and re-installed from a tested (correct file hash) DVD. Everything was fine, for half of a day. There were several updates that I installed from the official repositories. This is a “box-stock” O.S. install, no propitiatory drivers, and no non-free software (except Fluendo). Today, I noticed a slow down, and the hard drive activity light is once again, on constantly. I have not enabled any repositories except those installed during the DVD install. SMART thinks the hard drive is working correctly. I am typing this from the previous install of LEAP 42.2 (which I did not overwrite) and 42.2 is working correctly. System Monitor shows all cores below 20% (running only System Monitor, and Firefox browser). Does anyone have an idea on how I can pin this problem down (and hopefully solve it)?
Thank you,

4.4.79-18.23-default #1 SMP Thu Aug 3 15:17:07 UTC 2017 (535046c) x86_64 x86_64 x86_64 GNU/Linux
AMD FX™-6300 Six-Core Processor, 8GB ram, 2TB hard drive

Sounds like tracker indexing… you can disable via Settings → Search and Indexing. Run something like top to see what’s running, tail the log in a terminal window (root user and journalctl -f), Check no core dumps with coredumpctl list.

I believe you solved the problem I was having. I probably (certainly?) triggered the activity when I transferred all of my documents from the previous installation, to the new install of Leap 42.3. I did not anticipate that Tracker would try to read every word of many GigaBytes of files, (if indeed that is the case). I am not a great fan of Personal Ontology-Based (data) Management, but perhaps someday, when I looking for the “needle in the haystack,” I will use and appreciate it. I probably ignored Tracker because the name is periodically changed; Nepomuk, Baloo, Zeitgeist, Gnowsis, Tracker… I switched to Linux, because it simply works better, and then totally gave up, “The (paid for) U.S. based establishment operating system” because it seems to have no sense of, “This is mine - NOT yours.” For some reason, programs like Baloo and Tracker, raise my concern that Linux could be headed in a similar direction. Very nice to be able to disable features I do not use. I would have nothing but a worthless pile of plastic, and expensive circuits if it were not for the DEVs, and I am completely thankfull for their great efforts.
Thank You (again!)