Console TTY1-6 Keyboard Layout not country specific - always US QWERTY

Am I lucky that my passwords do not contain “y” or “z” or “#|+*~-_?=/” !!!

I’ve noticed that Leap 42.1 console TTYs 1 to 6 default to the US QWERTY keyboard layout.Despite the /etc/sysconfig/keyboard parameter KEYTABLE=“de-latin1-nodeadkeys”.

[INDENT=2]I have to execute “loadkeys de-latin1-nodeadkeys” before doing anything which is more than very basic on the console terminals.
[/INDENT]

Has anyone else noticed this behaviour?My 13.2 system doesn’t seem suffer from this issue.

Hi, I don’t know if German keyboards have special quirks :wink: but I see the ttys here taking the Italian KBD OK.
The config here is:


LT_B:/home/bruno # cat /etc/sysconfig/keyboard
...
# Keyboard mapping
# (/usr/share/kbd/keymaps/)
# e.g. KEYTABLE="de-latin1-nodeadkeys", "us" or empty for US settings
#
**KEYTABLE=""**
...
# ttys for the above settings 
# Example: "tty1 tty2"
# "" for tty's 1-6
#
KBD_TTY=""
...
# The YaST-internal identifier of the attached keyboard.
#
**YAST_KEYBOARD="italian,pc104"**
LT_B:/home/bruno #

So maybe you have to look for** ‘YAST_KEYBOARD=’ **and not ‘KEYTABLE=’ ? Otherwise it would seem that the ttys here should take en-us according to the KEYTABLE="" setting…

HTH

Ciao Bruno! Viva Europa!
The secret lies in the QWERTY/QWERTZ/AZERTY world!
Assuming that you are using an Italian QWERTY keyboard (and not an Italian QZERTY typewriter and, that you are not in the Italian speaking part of Switzerland – where they use QWERTZ keyboards) then, the difference to an US QWERTY keyboard is almost everything except “A-Za-z1-0”:Taking the top row of keys and “Shift:1-0” case first:
|US:|`|~|!|@|#|$|%|^|&|*|(|)|-|_|=|+||||
|—|—|—|—|—|—|—|—|—|—|—|—|—|—|—|—|—|—|—|—|
|Italian:||||!|"|£|$|%|&|/|(|)|=|Ꞌ|?|ì|^|||

Yes, the Italian QWERTY keyboard has one key less then the US QWERTY keyboard on the top row.]
And so on for the rest of the keyboard: please see Wikipedia:
<QWERTY - Wikipedia;

Even worse (leaving aside the German QWERTZ keyboard for the moment) for the French: the AZERTY keyboard (not the French ZHJAY typewriter):
<https://en.wikipedia.org/wiki/AZERTY&gt;
And now, the QWERTZ keyboard:
<https://en.wikipedia.org/wiki/German_keyboard_layout&gt;
I can only assume that the Nürnberg folks have taken a few too many lunch-breaks in the L’Osteria in the Pirckheimerstraße instead of being very Franconian and going to the Hexenhäusla.For those who do not know: Franconia (upper, lower and middle Franconia) has currently over 300 breweries . . .
And, therefore, I absolutely do not understand why the Maxfeldstraße folks have suddenly forgotten to support German console language machines . . . :wink:
By the way, I’ve had the pleasure of having to use the French AZERTY keyboard on a business trip to Brittany – being someone who was used to US QWERTY, GB QWERTY and German QWERTZ keyboards, it took quite a bit of searching before one discovered where the square brackets and braces were located . . .

Ciao Bruno!
By the way, assuming that you’ve set the YaST keyboard to “Bella Italia,pc104” then, IMHO an Italian console should be using one of the following values for KEYTABLE:

  • it2
  • it-ibm
  • it

[HR][/HR]Also, did you know that the annual Kulmbacher Beer Festival has a regular (large) group of Italian fans – they visit every year . . .
Booty Franconian.

German keyboard layout in text mode works fine here in my Leap VM.

But AFAIK the config has to be in the initrd already, so did you run “mkinitrd” after the change?

Also try KEYTABLE=“de-latin1-nodeadkeys.map.gz”, that’s what I have on my 13.2 system.

On my Leap VM, /etc/sysconfig/keyboard->KEYTABLE is empty though.
So try to set the keyboard layout in /etc/vconsole.conf, that’s the systemd way. Maybe the (openSUSE specific) /etc/sysconfig/keyboard is not respected any more.
It should contain something like this:

KEYMAP=de-latin1-nodeadkeys

See also “man vconsole.conf”.

And again, run “mkinitrd” after the change to be sure.

YaST should do the right thing though. If not, it’s a bug…

Servus Wolfi!
Yes, exactly as you’ve suggested:

  • In /etc/sysconfig/keyboard set the KEYTABLE value to an empty string.
  • In /etc/vconsole.conf changed the KEYMAP value from “us” to “de-latin1-nodeadkeys”.
  • Shutdown to the (old) “init” level ‘2’ – systemd translates it to something else but the “old” System V syntax still works.
  • Executed ‘mkinitrd’
  • ‘init 6’ (reboot)

Et voilà !*
[The /etc/vconsole.conf KEYMAP value of “us” is possibly the root cause of this issue – my 13.2 system has the “de-latin1-nodeadkeys” KEYMAP value.]

[HR][/HR]YaST however, is still misbehaving . . .*

Maybe the value from /etc/sysconfig/keyboard is only respected if it is not set in /etc/vconsole.conf, i.e. /etc/vconsole.conf overrides /etc/sysconfig/keyboard.
I’m not sure at the moment though.

On my 13.2 system the keymap is set in both (vconsole.conf has “KEYMAP=de”).

Confirming that vconsole.conf here reads “KEYMAP=it”.
Also noticed in the Yast2 “System Keyboard Configuration > Expert Keyboard settings” the following caption:
Here, fine tune various settings of the keyboard module. These settings are written into the file* /etc/sysconfig/keyboard***
So it is not as surprising that it misbehaves…

Not surprising at all! Auf Wiedersehen*

The “misbehavior” he was talking about is that YaST doesn’t show any keyboard layout at all for him.
In other words, he cannot even use YaST to change the keyboard layout.
As discussed here: https://forums.opensuse.org/showthread.php/513654-(also-13-2)-YaST-System-Keyboard-module-is-not-offering-any-keyboard-types
Actually I’m pretty sure that YaST does write /etc/vconsole.conf, I didn’t modify it myself in my Leap VM at least.