Connects but does not browse

I am using KDE
If I do


It works perfectly
But do not open any website
Other programs also do not have connection with the internet
This problem happens with cable or wireless
If I change my internet provider, I won’t browse either
I made a pendrive with an openSUSE live but it also gives the same problem
What can I do to fix this problem?

A DNS issue?

grep name /etc/resolv.conf

Are you using wicked or NM?

“ping” is not supposed to open any website.

You are providing very little useful information.

What do you see if you try:


It is possible that you have a DNS issue. If you can ping by ip address, but not by hostname, that suggests a DNS problem.

Can you also give the output from:

tail /etc/resolv.conf

Thanks for the answers
I try to use both, whicked and NetWork Manager
this photo was with whicked

The screenshot shows that your gateway router is acting as your DNS server. (The router is configured to do the DNS forwarding.) For some reason it isn’t working. You’d need to investigate the router to progress that perhaps. You could instead reconfigure your network connection with your preferred DNS servers directly.

As a quick test, do

echo nameserver 208.67. 222.222 | sudo tee /etc/resolv.conf

That will configure an OpenDNS nameserver on the fly. Check with




If that works, we can guide you on making such a configuration permanent.

After chang the nameserver the “ping” remains show “name or service not know”


grep hosts /etc/nsswitch.conf

Does it contain a ‘dns’ entry similar to the following?

hosts:          files mdns_minimal [NOTFOUND=return] dns


How are you setting up your DNS resolution?

  • Are you attempting to use “/etc/resolv.conf”?
  • Are you using “netconfig
    ”? – which is what you should be doing … - Have you setup your DNS resolution by using the files in ‘/etc/sysconfig/network/’? – which is what you should be doing …

[HR][/HR]The IPv4 address “” resolves to Alphabet’s Google DNS service:

 > dig -x

; <<>> DiG 9.11.2 <<>> -x
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 44306
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 4096
;          IN      PTR

;; ANSWER SECTION:   7372    IN      PTR

;; Query time: 21 msec
;; WHEN: Fri Oct 09 10:44:49 CEST 2020
;; MSG SIZE  rcvd: 73


If the machine is not portable – not a Laptop – then, and only then, you can point “netconfig” to your LAN’s Network Router as follows:

  • In “/etc/sysconfig/network/config”:

## Type:        string
## Default:     ""
# List of DNS domain names used for host-name lookup.
# It is written as search list into the /etc/resolv.conf file.

## Type:        string
## Default:     ""
# List of DNS nameserver IP addresses to use for host-name lookup.
# When the NETCONFIG_DNS_FORWARDER variable is set to "resolver",
# the name servers are written directly to /etc/resolv.conf.
# Otherwise, the nameserver are written into a forwarder specific
# configuration file and the /etc/resolv.conf does not contain any
# nameservers causing the glibc to use the name server on the local
# machine (the forwarder). See also netconfig(8) manual page.

  • For the case of a Laptop, you can either leave these parameters set to an empty string: ""
    or, - set the value of the DNS static servers parameter to “” …

If ‘/etc/resolv.conf’ is not a symbolic link pointing to ‘/run/netconfig/resolv.conf’, delete it and then reboot …
If you’re using “netconfig” properly then, simply, with the user “root”, execute “netconfig update” – possibly with the “–force-replace” option …


The default parameters in ‘/etc/nsswitch.conf’ are, in addition to the “hosts:” parameter, as follows:

passwd: compat
group:  compat
shadow: compat

hosts:  files mdns_minimal [NOTFOUND=return] dns
networks:       files dns

services:       files
protocols:      files
rpc:    files
ethers: files
netmasks:       files
netgroup:       files nis
publickey:      files

bootparams:     files
automount:      files nis
aliases:        files

Changing anything here is normally not necessary …

This is the result:

 hosts:          files mdns_minimal [NOTFOUND=return] dns

The device is a lapTop
If I set the value of the DNS static servers parameter to “” … Not work
When you say "If ‘/etc/resolv.conf’ is not a symbolic link pointing to ‘/run/netconfig/resolv.conf’, delete it and then reboot … " is telling me to delete resolv.conf?

The “netconfig” framework writes the value of the DNS static servers parameter defined in ‘/etc/sysconfig/network/config’ to the file generated at run-time: ‘/run/netconfig/resolv.conf’ – the directory “/run/” is not physically on a disk – it’s a directory in memory which the Linux Kernel sets up at boot time …

  • Because the C library resolver routines use ‘/etc/resolv.conf’ as their configuration file, it is set up as a symbolic link to the file created at boot time by “netconfig” …
  • By the way, the symbolic link is provided by a post-install action included with the RPM package “sysconfig-netconfig
    ” – simply forcibly reinstall the package and, the symbolic link will appear « RPM magic » … >:) - The package “sysconfig-netconfig” is required
    by the “wicked” and “NetworkManager” packages …

[HR][/HR]Yes, yes, I know – 7 times around the forest and 1 hundred times criss-cross through the forest before we can find Snow White and the seven Dwarves but, the people who have developed “netconfig” have chosen this solution and, that’s the way it is …

  • I have absolutely no idea as to when the C library resolver routines will be changed to use ‘/var/run/netconfig/resolv.conf’ in place of ‘/etc/resolv.conf’ …

This should not be so difficult.
Obviously, the problem is name resolution, either there isn’t a valid DNS server address in /etc/resolv.conf or the DNS server has a problem.
Although more troubleshooting can be done to further nail down a specific problem, it’s not necessary… All you need is a valid, working DNS server.


  1. Inspect /etc/resolv.conf
    You will find in the comments (lines starting with a #) instructions how to configure a static DNS server
    Key idea is that you should not edit this file directly unless you want your edits to last only until you reboot… and then your edits will be lost

  2. Following the instructions, you will need to open the following file in a text editor (remember, you must also have elevated permissions)

  1. Search for the following line (It’s way down in the file). If you’re using vim, you can type slash (/) and then character string you want to search, if you’re using a graphical text editor like Kate, use the “find” function from the menu. Or, just manually scroll, scroll all the way down until NETCONFIG settings appear and keep scrolling until you see the following
  1. Add the IP address of your preferred DNS server. If you want to use Google’s public DNS servers, one of them is what you’ve been testing,

  2. Save the file and although you can restart network services, if you have no objection I recommend simply rebooting.

  3. Problem should be solved.
    At least, assuming that your ISP isn’t blocking outbound DNS queries.


If you still have problems,
Then you should use one of several utililities (nslookup, dig, etc) to troubleshoot.
If nslookup,


Then type any FQDN Internet name you want. Your result should include the DNS server queried and the DNS query result.
If you want to switch to another DNS server (eg ISP DNS server, private DNS, anther public DNS server)

server *DNS_server_ip_address* 

Then re-run the FQDN you want to test.

Once you determine what works and what doesn’t, you should be able to narrow down the problem.


After editing the line


I rebooted and the internet went back to work
Thank you all