Connection troubles with a network with a nonbroadcasting id

Knetworkmanager seems to have problems connecting to a wireless connection that has a non-broadcasting essid, I have all the settings correct and everything thing but the only way I can get it to connect if I run

iwconfig wlan0 essid “NameOfNetwork”

ifup wlan0

and get the speech about how the device, wlan0, is configured with NetworkManager and that I should use that to connect after that checking KnetworkManager and it reads that the network I want to connect to has signal as apposed to before when it said that I had 0 signal straight and was unable to connect. This is my first time having to deal with a network that does not broadcast its essid so I have no clue if this is normal considering it has no problems connecting to public networks, MAC filtered networks, WEP/WPA encripted networks I figured I should ask about this.

Now you know why networks that do not broadcast their Essid are a lot
of trouble for no benefit. Not only does it take extra work to
connect, but you run the risk of having your neighbors tromp all over
your channel because they don’t see your network when they setup. As
to security, anyone with a snooper will quickly learn your Essid anyway.


If you want to connect to a hidden ESSID, have a look at PaulH’s contribution in the stickies


This isn’t mine, mine is mac filtered with a broadcasting ID the non broadcasting essid is being used at my college because the IT department doesn’t really know what they do.

Thanks DeltaFlyer I will.

If you are talking about this


This configuration is located in /etc/sysconfig/network/ifcfg-wlan0

I have tried and did not change anything still have to go through iwconfig to be able to connect to a hidden ESSID.