connection to NAS box

Okay. I have a NAS device that i want to be able to treat it like a local disk drive on suse. Right now i have a SMB share mapped as a short cut and i have to type in my password each time to access it… now this isn’t such a big deal - but it wont let me stream any audio or video from it.

Any ideas on how to make it a “mapped drive” like in windoze?

Thanks guys,
-Matt

what is your nas?

check nfs

Use a cifs mount and address the NAS by IP address. Something like this in the file system table fstab:

//192.168.44.100/nas_name /path_to/mount_point cifs
nobrl,_netdev,uid=your_suse_username,gid=users 0 0

If the NAS has been configured to use a login you would need to add those creds into the options, e.g. changing the options bits to like this: username=nas_Uname,password=nas_Pwd,nobrl,_netdev,uid=your_suse_username,gid=users
This might be worth a read:
Samba: HowTo Mount a CIFS Network Share [AKA Map Network Drive] in openSUSE 10 & 11 plus FAQs

Ahh i see.
Okay the link was very helpful but I still am having some permissions issues… Not sure why though.
I filled everything in properly and it mounts the share in “Storage Media” and when i click on the share it says “Permissions Denied”. But if I just navigate to the share \192.192.1.100\path, or use smb, it then asks me for the same user and password and works just fine. I’m not sure whats going on.

It’s a Galaxy Metal Gear Box NAS pro 3500 with a Raid 1. This device is setup with a linux filesystem but i have always used it with my windows box… which is now my suse box. The permissions are set for one user and one folder.

This is what I put fstab:

//192.168.1.104/admin / cifs username=admin,password=PASSWORD,_netdev,uid=matt,gid=users 0 0

any ideas?
Thanks,
-Matt

In this the mount point is simply “/”, the slash between “admin” and “cifs”:
//192.168.1.104/admin / cifs username=admin,password=PASSWORD,_netdev,uid=matt,gid=users 0 0
You are mounting the share into the very bottom root of the root directory, which I’ve never seen before, and it’s almost certainly not allowed.

So create a real mount point for the shared files to appear in, e.g. directory NasFiles located at e.g. /home/matt/NasFiles and change the line to this:
//192.168.1.104/admin /home/matt/NasFiles cifs username=admin,password=PASSWORD,_netdev,uid=matt,gid=users 0 0

Something like that. Then reboot and look into directory NasFiles.

I was wondering if should put a directory there or just leave it at root…

But, I still get the same thing - even after a reboot.

This is weird - I even tried using netbios name (is it even called netbios name in linux?) with the same results.

One thing I did notice was that when I rebooted it poped up with a login screen (atleast thats what it looked like) in the upper left hand corner then quickly went away. No errors thrown at that point and time.
But if i look under Storage Media the mapping is there and still says “Permissions Denied” and the folder /home/matt/Nas_Files is still empty.

Thanks for all your help man, but any other ideas?

Like I said I dont care I have to type in my password or anything, but I just want to be able to stream from it. Right now, I have to copy over anything to watch/liten to.

I’m getting confused trying to see what you see. Our communications are cloudy. These eight questions should make it easier for me:
Q1: What is “Storage Media”"?
Q2: Which version of Suse are you using?
Q3: which Desktop, KDE3, KDE4, Gnome?

Open your network browser (Nautilus/Konqueror/Dolphin) and enter htis address exactly:

smb:/

Q4: You should see a singkle icon, is that right?
Q5: The name beside the icon is the single workgroup name. What is it?
Q6: When you click the icon for the workgroup you should see shares, one of which is the NAS. What is the NAS called in the browser?
Q7: when you click the icon for the NAS it should drill down to the share that you’ve been trying to access. What name is beside the icon for the share?
Q8: when you click that share’s icon you say you are asked for a username and a password. What are those credentials?

From these details we should be able to build the right line to put in fstab.

On Thu December 25 2008 09:56 pm, swerdna wrote:

>
> I’m getting confused trying to see what you see. Our communications are
> cloudy. These eight questions should make it easier for me:
> Q1: What is “Storage Media”"?
> Q2: Which version of Suse are you using?
> Q3: which Desktop, KDE3, KDE4, Gnome?
>
> Open your network browser (Nautilus/Konqueror/Dolphin) and enter htis
> address exactly:
> Code:
> --------------------
> sbm:/
> --------------------
>
> Q4: You should see a singkle icon, is that right?
> Q5: The name beside the icon is the single workgroup name. What is it?
> Q6: When you click the icon for the workgroup you should see shares,
> one of which is the NAS. What is the NAS called in the browser?
> Q7: when you click the icon for the NAS it should drill down to the
> share that you’ve been trying to access. What name is beside the icon
> for the share?
> Q8: when you click that share’s icon you say you are asked for a
> username and a password. What are those credentials?
>
> From these details we should be able to build the right line to put in
> fstab.
>
>
Did you mean?


smb:/


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

Of course I did! I’m not as thunk as some drinkle peep I am!

On Thu December 25 2008 11:26 pm, swerdna wrote:
<snip>
> Of course I did! I’m not as thunk as some drinkle peep I am!
>
The only good thing about getting old is that I get to blame these things on a
senior moment :wink:


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

Q1: What is “Storage Media”"?
When I open Konqueror system browser I see “documents folder” “home folder” “remote places” “STORAGE MEDIA”… listed there. That’s where i see the storage media folder.
**
Q2: Which version of Suse are you using?**
11 64bit
Q3: which Desktop, KDE3, KDE4, Gnome?
KED3
Open your network browser (Nautilus/Konqueror/Dolphin) and enter htis address exactly:
Code: smb:/

When i type “smb:/” i get this popup “Unable to find any workgroups in your local network. This might be caused by an enabled firewall”.
BUT, if i hit smb://192.168.1.104 … it takes me to the NAS share. (but i can’t stream video or audio)

Q4: You should see a singkle icon, is that right?
When i go to “smb://192.168.1.104” i see a folder called “admin”, and that is the share inside of the nas.

Q5: The name beside the icon is the single workgroup name. What is it?
WORKGROUP

Q6: When you click the icon for the workgroup you should see shares, one of which is the NAS. What is the NAS called in the browser?
The netbios name of the NAS is “Heathian” >:)
The IP is 192.168.1.104

Q7: when you click the icon for the NAS it should drill down to the share that you’ve been trying to access. What name is beside the icon for the share?
The share name is ‘admin’

Q8: when you click that share’s icon you say you are asked for a username and a password. What are those credentials?
The username is “admin”, and the password is “PASSWORD”…

:slight_smile:
Hope that helps.
I’m currious about the error i get when i go to smb:/ - wonder if that has something to do with all of this…

Thanks man for your help,
-Matt

A quick note. I disabled my firewall (temporarily) and it allowed me to get to “smb:/”.
I could see the nas and the share, it was the same as me just typing in the ip, but when i try to play a video in mplayer I get the same problem of it wanting to copy over the movie instead of just playing it remotely.

Just throwing more info in there.
-Matt

Hmmmm… cifs software??? Check these RPMs are installed: samba, cifs-mount, pam-cifs (if available I can’t remember for 11.x), samba-client, kdebase3-samba.

If you’re using openSUE 11.0 then the firewall can be opened by the method on this link.

If you’re using openSUE 11.1 then then you have to use the method on this different link to open the Firewall. OpenSUSE 11.1 developed a bug that makes opening the firewall complicated. (the bug’s linked in my sig if interested).

Anyway, try opening the firewall. Test it with smb:/ in your browser to see if it is open. Then you can test the line in fstab by rebooting. According to your data, this should be the line in fstab, all in one line:

//192.168.1.104/admin /home/matt/NasFiles cifs username=admin,password=PASSWORD,_netdev,uid=matt,gid=users 0 0

But that’s what you had so try the firewall thing (which I doubt is the problem) and the cifs software, particularly cifs-mount.

Negative. Still same thing.

I really dont have anything else here to test a share folder on another machine, as I’m sure everything is set right. I am willing to bet its an issue with the NAS itself…
Here is a screen shot of a section of the configuration that I bet might help… take a look and let me know if you see anything?

http://www.jumblestudios.com/screenshots/snapshot1.jpg

Thanks for all the help yo,
-Matt

Also let me reiterate that the issue isn’t with me not connecting to the device via smb, the issue is with me not being able to stream anything from the device. I just initially thought making a mapped drive or mount would be the correct solution…

I wonder if the Traditional Chinese is a problem?
Also, guest access has been enabled. Is that dovetailing with giving a username and password for the server. Maybe should try it for sending no credentials to the server from the line in fstab.

What’s it say under Share Management?

Everything you see there is what was default and what worked in windows environment.

The Guest Access Setting?
Well, when you setup the box you have to create a user account to make permissions for any folders/shares. So by default there are no accounts and there is a public folder and a ‘guest-share’ folder. These two are open to the network so thats why I created an admin account with its respective admin folder. (tested it with this off and on, no changes)

I did try making a cifs mount to those two ‘open’ shares with same problem about permissions.

If I turn off the ‘windows setting’ I cannot connect to the device at all.

For the heck of it i just switched the chinese character set to english with no change.

I just dont get how in windows I can map to it AND stream from it. But in linux i’m having such trouble. I would think it would be easier, especially since it’s a linux os on the nas.

Are you able to examine the logs on the NAS to see what its objection to your login is?

I looked into the samba setup on a NAS once because I was having great trouble connecting to it from an all-windows LAN. I examined the smb.conf and so on. The Linux was so elementary as to be barely functional. That explained to me why I could only connect using IP addressing. I was very disappointed in the slack way the thing had been softwared. Can’t remeber the brand name – very respected one though.

And I just can’t get my network to perform at a reasonable level to assist with queries like yours. I must say that I’m very disappointed with the networking in openSUSE 11.1. It’s flawed in too many places. I know yours is 11.0 but that too was downhill from 10.3, which is the top networking product from the 10.x 11.x series so far.

On Sat December 27 2008 05:16 pm, getintanked wrote:

>
> Everything you see there is what was default and what worked in windows
> environment.
>
> The Guest Access Setting?
> Well, when you setup the box you have to create a user account to make
> permissions for any folders/shares. So by default there are no accounts
> and there is a public folder and a ‘guest-share’ folder. These two are
> open to the network so thats why I created an admin account with its
> respective admin folder. (tested it with this off and on, no changes)
>
> I did try making a cifs mount to those two ‘open’ shares with same
> problem about permissions.
>
> If I turn off the ‘windows setting’ I cannot connect to the device at
> all.
>
> For the heck of it i just switched the chinese character set to english
> with no change.
>
>
> I just dont get how in windows I can map to it AND stream from it. But
> in linux i’m having such trouble. I would think it would be easier,
> especially since it’s a linux os on the nas.
>
>
gitintanked;

Have you tried using smbclient directly from a terminal? First try this:


smbclient -L //<NAServer> -U guest

Do you get errors? Does it provide a list of the shares? If this works read
on. can be a netbios name or IP.

If I recall you have shares “admin” and “guest” on the NAS. With a user also
called admin. So try this:


smbclient //<NAServer>/admin -U admin

Enter admin’s password at the prompt and you should see:


smb: />

You can now issue various commands, such as ls, get, put, cd, and the
important, exit, to leave. For a complete list of these commands see:


man smbclient

Hopefully, you will get an error message at some point which gives a hint as
to what is wrong. If smbclient works, the problem must be in the GUI.
A “mount.cifs” command may help here. ken yap has suggested the log files on
the NAS but also look here on Suse to see if anything pops out at you.
/var/log/samba/log.smbd.

P. V.
“We’re all in this together, I’m pulling for you.” Red Green

Great question! I can’t believe I didn’t think of that…

http://www.jumblestudios.com/screenshots/snapshot2.jpg

Okay, so i cleared out my logs and connected via smb (the way that works) and entered my username and pass and the first line shows a successful connection. Then I tried with the mounting via cifs by adding the line to my fstab, where i get the permissions deneid error, and the second line you see there is what is logged when that happens.

P.V. -> I’m going to post on your suggestions in just a minute.

-Matt