Connection through proxy server (openSUSE 12.3)

This is my first thread, so if something is not correct or not the way you like it, don’t hesitate to say it.

I’ve installed openSUSE 12.3 in a virtual machine. As host I use a Windows 7 64bit environment with the latest Virtualbox version. I want to learn a bit to use a linux system. I’m an IT professional but I’ve worked so far mostly only with Windows operating systems.

The installation went well. But there is a serious issue that I can’t solve: the virtual machine doesn’t work with the proxy server in the network. The proxy server is used to access the internet. I went so far to disable the network manager and used yast instead, but that doesn’t help. If I configure the same proxy directy in Firefox instead of the option to use the system settings, Firefox can connect to the internet.

The network settings of the virtual machine are correct. The DNS server is correct. All the settings came from the DHCP and are ok.

Just to test the Virtualbox installation I’ve also set up a virtual machine with the latest Ubuntu version and one with Windows 2008 R2 and both machines work perfect with the proxy settings.

When I’m in another network that doesn’t use a proxy for external connections, then everything works fine (as soon as I uncheck the proxy settings).

Does anyone has an idea what could be wrong or where I could also check the settings? Thank you in advance!

I forgot to mention that the used proxy is an ISA Server 2006 (that wasn’t my choise ;-)).

Which desktop environment are you using? Have you tried to setup the proxy server in YaST?

On 2013-03-21 15:06, CivisRomanum wrote:
> The network settings of the virtual machine are correct. The DNS server
> is correct. All the settings came from the DHCP and are ok.

I’m not familiar with virtualbox settings, so I’ll assume they are
similar to vmware. There are three ways to setup the virtual network
ethernet port. In one, it behaves as a different port in the same
network as the host, so that the guest behaves as a separate machine in
the same network, getting the settings from the same dhcp server as the

In another, the guest(s) is set into an internal network of the host,
routing packages to the outside. It is not visible from outside the
host, because it does NAT. In this mode, I think that you would not need
to setup proxy in the guest.

In another, the guest(s) gets an internal network in the host totally
isolated from the outside. No internet.

Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Thank you for the replies.

@robin_listas: I’m using the “bridge” option for establishing a network connection for the virtual machine. Everything works fine except the connection to the internet.

@katanacb: I’m using KDE. Yes, I tried at the end with Yast. This doesn’t help for Firefox or to make an update of the packages.
I’ve just read your thread* where you describe the same issues. Where can I configure the proxy for KDE? I’ve done it so long with Yast and Firefox.
Does that mean that I have to configure the proxy for every single application?

If this was a Microsoft product, I would say that this is a mayor bug in the OS. :smiley:

Sorry, I’ve been offline for awhile dealing with some personal things.

yes, I started a similar thread, and so far, I have to configure things in 3 different places. This is why I’m still using ubuntu 12.04 for my desktop machines, because it shouldn’t be this way. I think it’s more of a KDE issue vs an OpenSUSE issue, but in Ubuntu I only have to configure the proxy server settings in 1 place and all works well.

in SLES 11 SP2, it’s the same way with GNOME 2, I configure the proxy in YaST and the system honors it instantly. In KDE this doesn’t seem to work the same way, unfortunately. Maybe need to file something upstream.