connection rate at 1M

Hi,
I have had slow connection speeds since changing to 11.2.I have set local DNS and removrd ipv6 and still had probs.
Been through the very useful FAQ post, many thanks to the author. It seems to be that my prob is the last one on this post where I get a speed of 1M set. I add details of my setup and hope I can get this set.

kernel
2.6.31.12-0.1-default

card from hardware
78: udi = ‘/org/freedesktop/Hal/devices/pci_1814_301’
pci.product = ‘RT2561/RT61 802.11g PCI’
pci.subsys_vendor = ‘Linksys’
linux.hotplug_type = 2 (0x2)
linux.subsystem = ‘pci’
info.linux.driver = ‘rt61pci’
info.subsystem = ‘pci’
info.product = ‘RT2561/RT61 802.11g PCI’
info.udi = ‘/org/freedesktop/Hal/devices/pci_1814_301’
linux.sysfs_path = ‘/sys/devices/pci0000:00/0000:00:1e.0/0000:05:01.0’
info.parent = ‘/org/freedesktop/Hal/devices/pci_8086_244e’
pci.linux.sysfs_path = ‘/sys/devices/pci0000:00/0000:00:1e.0/0000:05:01.0’
pci.product_id = 769 (0x301)
pci.vendor_id = 6164 (0x1814)
pci.subsys_product_id = 85 (0x55)
pci.subsys_vendor_id = 5943 (0x1737)
pci.device_class = 2 (0x2)
pci.device_subclass = 128 (0x80)
pci.device_protocol = 0 (0x0)
pci.vendor = ‘RaLink’
info.vendor = ‘RaLink’
pci.subsys_product = ‘WMP54G ver 4.1’

If other details are needed please let me know.
all replies appreciated.
Thanks

Been through the very useful FAQ post, many thanks to the author.

Which way did you follow? I have written another HowTo → here since there’s a YaST-bug in SuSE 11.2. Don’t forget to reboot afterwards so the setting will take effect.

Hi,
I followed the above sticky for getting your wireles to work.I had previously disabled the ipv6 from yast network setup, and sure enough mine is 64bit.
I have now done as per your post edited the menu.lst and hope for better.
Will this affect where I am seeing the rate at 1M in iwconfig? If not I still will need to resolve this.
Thanks for the reply and help.

I too had slow performance after installing 11.2. I noticed that the ipv6 settings were new and looks rather non-optional. I did some searching and found this article. After I added
ipv6.disable=1
to the end of my kernel line in /boot/grub/menu.lst my network performance is back to usual. I don’t know if this will help your issue or not but it has really helped me.