Connecting USB External Modems

Hi Open Suse

We have a registered copy of 11.0 up and running on a 64 bit machine. We now want to get a D Link V.92 56K Data Fax DU-562M USB Modem working. The modem is plugged in to the computer and the telephone line and the light on the modem is on. However we don’t know what to do next.

Cheers

Robert

Robert D Davidson
Director
Genatron Ltd GENATRON
:wink:

For internet connection? If “yes” then Configure the modem in Yast → Network devices → Modem

Hi Swerdna,

Yes I have been talked through that far by NZ contact but the plug with the lightning coming out of it didn’t light even when an ASCII config string was put into YAST.

Cheers

Robert

Hi Swerdna,

Sorry the Kinternet icon actually shows lightning but the modem doesn’t dial and the log is

Suse Metta pppd (smpppd-icfcg) Version 1.59_SVN16 on Linus d7o6
Status is disconnected
trying to connect to smpppd
connect to smpppd
Status is disconnected
Status is connecting
pppd[3] Pluging password fd is loaded
pppd [3] Failed to open /devfusbdev1.1_ep()() No such device or address
Status is disconnected
ppp[3] died Serial port open failed (exit code 7)

Cheers

Robert

so you go to Yast: you enter your root password; you select network devices and then modem;

then you add a device: is yours listed?


sounds also like we need to find what port the modem is assigned to;

here is a description from another linux forum on how they configured a similar modem

Choosing external modem for Ubuntu [Archive] - Ubuntu Forums

My D-LINK DFM-56EL external modem now works with Ubuntu 6.10 (the mouse did not work on 7.04).

Here is how I installed it:

  1. downloaded Gnome-ppp using another computer. Copied to CD.

  2. inserted CD in CD-drive on Ubuntu PC.
    An icon representing the CD becomes visible in the Ubuntu window.

  3. double-clicked on CD icon to install gnone-ppp.
    The installer puts the Gnome dialer in the same
    submenu as Firefox, Evolution mail etc

  4. click GNOME PPP submenu item and enter Username, Password
    and telephone number (in my case from a prepaid Internet card)

  5. Click Setup button at the bottom of the GNOME PPP dialogbox.

Select device from dropdown list

/dev/ttSy0 corresponds to Windows COM1
/dev/ttSy1 corresponds to Windows COM2

Select device type from dropdown list: ‘Analog Modem’ in most cases

Select modem speed: 57600 for a 56K modem

Leave all other settings as they are. Close Setup

Click Connect button on GNOME PPP dialog and you will hear
the modem connect signalling.

you can see they used a PPP programme, and their device was assigned to /dev/ttsy0

(I remember such terms from our days of a dial-up modem);

here is an entry from another linux forum

dial up setup was “How do I dial using external modem” - Linux Archive

I have a USRobotics usr 5637
that works, plug it in and setup on ttyACM0.
During the pppconfig setup, where it cannot find your modem, you will
need to select manual and put in
ttyACM0 that usually works for me If you put your ISP in the “Provider”
line, you will need to type
pon and “what you put in the provider line” If it wasn’t changed pon
should work.

so they recommend a setting they call ttyACM0

can you see any such possible settings

___________-

the worrying thing too is that this guy

gnulinuxclub.org - Configuring Ethernet Modem On LINUX Machine

seems to know about configuring USB modems; and recommends being very wary of them …

so see if you can give us some of the information as above

you based in Wellington, NZ?

also suggest you think of contacting this group

Wellington Linux User Group (WellyLUG)

Have a look at how I connected a modem and set it up on KDE – it was for broadband wireless but principle is similar to 56K.
Wireless broadband in Suse/openSUSE for Bigpond Next G Network (HSDPA-enabled bp3-usb)

And then there’s the method of pdc_2 for Gnome – should see you right too.

PS don’t forget to turn on the smpppd daemon in Yast → system → system services runlevels.

Hi PDC_2

Yes I go to yast and the modem seems to be there but is just says Device = “modem()” Type=Modem Provider=Worldnet (My ISP) They guy that was helping me entered some sort of ASCII string somewhere,but now he has gone to ground.

I am way out in the middle of the Hauraki Plains surrounded by 100,000 cows and 6000 well meaning, but totally Linux illerate, locals.

Cheers

Robert

Hi Swerdna,

I managed to get into the superuser shell and type in your dsmeg (whatever that stands for) command and it worked but didn’t find the file because I hadn’t copyed it to the desktop. Can you tell me where the dsmeg.txt file is and how I copy it to the desktop. Also the graphic email on your webpage didn’t display on my browser.

Cheers

Robert

Hi Robert

If you want to read about “dmesg”, enter this command in a console window:

man dmesg

If your username is e.g. your_name, then this command will copy the dmesg file to your desktop:

dmesg > /home/your_name/Desktop/dmesg.txt

Hi Robert; Swerdna is the expert on this and I am going to hang back from the main advice but when you say:

I managed to get into the superuser shell and type in your dsmeg (whatever that stands for) command and it worked but didn’t find the file because I hadn’t copyed it to the desktop

you did what was needed by typing in dsmeg; if you trawl through all the large amount of information in the shell window, Swerdna is suggesting you will … somewhere … find something like his example from his link:

Then you should find something like this at the tail of dmesg
usb 2-4.4: new full speed USB device using ehci_hcd and address 8
usb 2-4.4: new device found, idVendor=16d8, idProduct=6280
usb 2-4.4: new device strings: Mfr=1, Product=2, SerialNumber=4
usb 2-4.4: Product: CMOTECH CDMA Technologies
usb 2-4.4: Manufacturer: CMOTECH CO., LTD.
usb 2-4.4: SerialNumber: Serial Number
usb 2-4.4: configuration #1 chosen from 1 choice

and swerdna was suggesting that another thing to do; that might be helpful; is to make the computer copy all the information in the terminal; into a simple text file; and then you can read it, or print it out or whatever;

so when he says:

If your username is “username” you can copy dmesg to the Desktop and then examine it with this root shell command:

dmesg > /home/username/Desktop/dmesg.txt

that is telling the terminal: (having typed in your root password) to copy what you can already see and read; into a text file;

if you get the above, copy and paste it back here;

to copy and paste into and out of terminals, best use the Edit menu on the top line, as the terminals do not control-C and control-V but things like shift-control-C …

I hope I am not labouring the explanations too much; just trying to assist!!

Also try typing

lsusb

into a terminal, and post that back to us too; it maybe helpful; it says what your various USB ports are linked up to etc