Connecting to wireless router

HI company
I am a newbie to openSuse 11.2 (I have just downloaded and installed it).
My first problem is that when I open KNetworkManager the wireless tab is desibled,I don’t know why!!!
My laptop is HP pavilion dv6-1245DX.
Any one couls help me to get connected to my wireless router?
Thank you at advance

I have the same problem. I think to get help you need to go through the steps in the sticky’s and post the results. [rant: To me it is beginning to look like 11.2|kde has a lot of small problems to sort out; on my desktop I gave up and reinstalled with gnome. Now it is wrestling with wireless on my netbook (which works fine with Ubuntu, XP, and 11.1].

Open a terminal and type the following:

/sbin/lspci -nnk

Post result

Thank you company for all answers,I’ve tried that command but nothing happen just dome info and as you know I;m a newbie to Linux,and also i tried to install Gnome,I found that I can connect to a wireless router but I set all the data of the configuration ,but nothing happened,I also tried to download wireless driver of my laptop from hp site,i found that there is no driver for any linux OS.
I think there is something messing with KDE to support wireless,someone knows the solution?
Thank you

I’ve tried that command but nothing happen just dome info

I’m going out on a limb and assume you mean ‘some’ ?

We need that info to help you. LOL:)

Amirale,

Maybe my experience will be helpful, since I gather from the limited information, I may be experiencing the same problem.

I am now able to connect via the “traditional” method, but I have been totally unsuccessful via Network Manager. I ran across a post of the steps (but I now that I want to reference it I can’t find it!). What I did was:

  1. Yast|Network Devices|Network Settings|Global Options tab and change to ifup.
  2. Overview tab, select wireless adapter, Click Edit
  3. Click Next (assuming you want to retain DHCP)
  4. Click Scan Network. If this picks up your router’s SSID then it is “sort of working.”
    Select the type of encryption key
    Enter your encryption key
    Next
  5. Hostname/DNS tab.
    Manually enter IPs for DNS server(s), e.g. 4.2.2.5
  6. Select Routing tab
    Enter gateway IP for your router, e.g. 192.168.1.1
    OK

Try something on the internet. If that does not work see if you can ping your router, e.g. in a terminal window–
ping 192.168.1.1

If that works, but something like ‘http://www.google.com’ fails, then most likely something wasn’t correct with the DNS Server entry.

Another thing to try is–
/usr/sbin/iwlist scan
This should show the same routers as in the Yast…setup.

At the moment everything seems to be pointing to Network Manager having a problem. The recent update fix may have fixed one problem, but uncovered another. I don’t know that much about it, but via re-installing 11.2 I stumbled on to ‘iwlist scan’ producing output that looked like all was working, but after the update it showed the network down. Switching to the traditional setup mode now has it working with the router, but in spite of DHCP, the DNS and gateway IP addresses had to be entered manually.

Thank you everybody but still nothing,I don’t know whats the problem,my wireless card is Intel for HP laptop dv6

Getting Your Wireless to Work - openSUSE Forums

My wireless doesn’t work - a primer on what I should do next - openSUSE Forums

Please, don’t get annoyed, the card in your laptop should be supported, so it’s a configuration problem. Follow the links Akoelh provided, take your time to read carefully, get back here if you don’t succeed.

and if you go here

Benutzeranleitung/Usersguide von/of collectNWData | collectNWData.sh

and download and run this diagnostic script, it may well give you all the answers you need;

the script is supported by this forum

I know for my laptop, (which is older), on the main Gnome desktop, if you look at the bottom right corner there should be a set of blue signal bars. right-click those and a list of wireless access point should show up. click on yours, enter your key (wep, etc), and you should be good. Don’t know if that will help, but always go for the easiest solution first

-cheers