connecting to samba shared printer from win vista

Hi all! My first time in this forum. And I already start with a very complicated case.

I’ve a server opensuse 10.3 running Samba 3.4.1-6.1.
This server has shared printers installed on samba with its driver through ‘cupsaddsmb’, everything works very fine in WinXP Pro.
When I try to connect from Win vista (home or business, same effect), win vista can download the printer’s driver, but cannot connect.
It gives error code (0x000006f7).
After trying a lot of things like disable ipv6, QoS, smb related keys in regedit, etc… I got nothing, but the same error code.

I have a tcpdump capture file from wireshark with the packages from my connection with the samba printer.

I think everything is alright with my ‘smb.conf’ because it works very fine in WinXP (Donwload the driver and install the printer, very fast…)

Even the driver that a thought could be wrong for vista, I tried to change, but didn’t work…

Guess I can’t post attachments, so if someone want to see my tcpdump file, ask me.

Any help, will be very wellcome…