Connecting to Cisco SSL VPN on openSuSE 13.1


I’ve tried to use the network manager gui to set up a vpn session to a Cisco ASA setup for SSL VPN.
I could not get this to work,

I then tried using the officiel path - the anyconnect client. I had a copy of the newest 64bit version for linux so tried with that.
This also fails. On the command line version I get the following output:

  >> state: Connecting
  >> notice: Establishing VPN session...
  >> notice: Connection attempt has failed.
  >> error: The AnyConnect package on the secure gateway could not be located. You may be experiencing network connectivity issues. Please try connecting again.
  >> state: Disconnected

Ofcourse the gateway has a much older version of anyconnect which I haven’t fiddled with.

As a last resort I installed openconnect and tried to use that with the following command:

openconnect -s /etc/vpnc/vpnc-script -u kristian.larsen -v fw.domain.tld

That ALMOST worked - it connected, but my DNS servers didn’t get changed. And while a tunnel is better then none, for my purposes I really do need DNS.

I’ve tried various searches and couldn’t find anything really helpfull. So if you could help with pointers to get openconnect working then I can document the progress here and hopefully it will help someone in the future.

Just install vpnc and create a suitable conf in /etc/vpnc/cool_name.conf which includes;

IPSec gateway
IPSec ID your_group_name
IPSec secret password_for_the_group
Xauth username your_username
Xauth password your_password

Then launch: vpnc --debug 1 /etc/vpnc/cool_name.conf

Thanks - that would be the correct solution for IPSec VPN - SSL VPN is a different beast.
VPNC is installed since I’m trying to use the vpnc-script

My problem is simply: VPN software should update DNS servers so that DNS works after VPN tunnel is established.
Currently I get the tunnel up and running but like I noted, I really do need DNS as well.

Bloody hell, I misread that you were using IPSEC - my apologies.

That’s what happens when you reply without thinking and expect things :stuck_out_tongue:

No worries :slight_smile: