Connecting problem with encryption openSUSE 11.0

Hello all.

On a totally clean openSUSE install im having problems with connecting to my wireless network. Im using WPA2 encryption. My network card can see all available networks and when i try to connect to my network it prompts me for a password which i enter. It tries to logon to the network but failes. I dont get any error messages or what so ever. Every 10th minut or so it prompts me for the password once again.

I’ve tried to connect to unencrypted networks and that works like a charm.

My network card is Intel Wireless WiFi Link 4965AGN and my wireless router is broadcasting (or what ever it is called) on channel 2.

If you need any other information just tell me. Any help will be appreciated!

I found the problem and i guess you’re just gonna laugh now.

Just now when i tried to go online on my other computer which is running windows and was the one i posted from yesterday i had problems getting an IP from the router. So i restarted the router and now the wireless network also works on my openSUSE installation. If had just been given some sort of error message then maybe i would have figured it out :frowning: