Connecting bluetooth Microsoft keyboard in 13.1

Hello,
I’m trying to connect Microsoft bluetooth keyboard but without a success. With the Microsoft BT mouse I didn’t have problems and it works just fine.
Bluetooth is working and it finds the keyboard and its MAC address. Via graphical interface I am able to select the keyboard and to start the pairing process which gives the pairing code to enter, which I enter via BT keyboard and it passes well.
However, afterwards when keyboard is paired and seams everything went fine it fails to connect. After some time it pins notification: (KDE workspace Microsoft keyboard: Input service connection timeout)
In the terminal using hcitool:

user@linux:~> hcitool scan
Scanning ...
        00:12:5A:9E:3C:88       Microsoft Keyboard
atedalv@linux-precise:~> sudo l2ping -c 4 00:12:5A:9E:3C:88
Ping: 00:12:5A:9E:3C:88 from C0:18:85:D7:80:CF (data size 44) ...
0 bytes from 00:12:5A:9E:3C:88 id 0 time 7.48ms
0 bytes from 00:12:5A:9E:3C:88 id 1 time 6.28ms
0 bytes from 00:12:5A:9E:3C:88 id 2 time 7.21ms
0 bytes from 00:12:5A:9E:3C:88 id 3 time 7.42ms
4 sent, 4 received, 0% loss
user@linux:~> sudo hcitool cc 00:12:5A:9E:3C:88
user@linux:~> sudo hcitool auth 00:12:5A:9E:3C:88
Not connected.

If I use alternative way like:

user@linux:~> bluetoothctl 
[NEW] Controller C0:18:85:D7:80:CF linux.jozmi [default]
[NEW] Device 00:12:5A:9E:3C:88 Microsoft Keyboard
[NEW] Device 00:12:5A:9D:E6:F0 Microsoft Mouse
[bluetooth]# list
Controller C0:18:85:D7:80:CF linux.jozmi [default]
[bluetooth]# select C0:18:85:D7:80:CF
[bluetooth]# power on
Changing power on succeeded
[bluetooth]# scan on
Discovery started
[CHG] Controller C0:18:85:D7:80:CF Discovering: yes
[CHG] Device 00:12:5A:9E:3C:88 RSSI: -43
[bluetooth]# devices
Device 00:12:5A:9E:3C:88 Microsoft Keyboard
Device 00:12:5A:9D:E6:F0 Microsoft Mouse
[bluetooth]# trust 00:12:5A:9E:3C:88
Changing 00:12:5A:9E:3C:88 trust succeeded
[bluetooth]# pairable on
Changing pairable on succeeded
[bluetooth]# pair 00:12:5A:9E:3C:88
Attempting to pair with 00:12:5A:9E:3C:88
Pairing successful
[bluetooth]# connect 00:12:5A:9E:3C:88
Attempting to connect to 00:12:5A:9E:3C:88
[CHG] Device 00:12:5A:9E:3C:88 Connected: yes
Connection successful
[CHG] Device 00:12:5A:9E:3C:88 Modalias: usb:v045Ep0099d0010
[CHG] Device 00:12:5A:9E:3C:88 Modalias: usb:v045Ep0099d0010

This seams like a device is normally working but after I start typing on a newly connected keyboard I get Segmentation fault crash as:

Application: Bluetooth (bluedevil-monolithic), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]

Don’t know what I am doing wrong. I would really appreciate help on this matter or some alternative workaround. Everything else work excellent on this new release.

IIRC blutooth is broken in KDE for 13.1

Thanks for the response. It was confusing as BT mouse works normally and keyboard pairs but does not connect.
Does anybody know when this issue will be fixed ?

Is this still an outstanding bug, having issues connecting a magic mouse. Not sure whether its related to it being a magic mouse or KDE bluetooth issues.

Cheers
William

https://bugs.kde.org/show_bug.cgi?id=327765

Logged by bug seems to be a duplicate of this one. Hopefully it gets fixed soon.

Cheers
William