Connected to wireless but not to internet

Hello everyone,

I am new to openSUSE but not to linux in general. I wanted to try out SUSE (Gnome) on my laptop after having used Fedora for a long time.

Install went fast and smooth, no problems what so ever. However, after install I have a strange network problem.
I can connect to wireless networks without a problem, however I can not connect to the net.

Network adapter is a Ralink RT3290, but it is recognised by the system.
ifconfig and iwconfig don’t give anything strange. Shows the network card, shows the connection.
I get an ip-adress
I have tried using google dns servers but that doesn’t help.

But I can’t even ping something, there is absolutely no data flowing.

Can anyone help me diagnose this some more or help me resolve it?

Running OpenSUSE 13.1 on a HP DM1

Hello and welcome here.

Please allways show us what your computer tells you. Only posting your conclusions do not provide enough information. After all you want our advice and thus our conclusions.

Thus when you say “however I can not connect to the net.”, you should tell us (better show us) why you think so. E.g. by doing something like

ping -c1

Also saying “ifconfig and iwconfig don’t give anything strange” only tells us that you think there in’t something strange. but in fact it does tell nothing (we are non believers :wink: ). To convince us, show the prompt, the command, the output and the next prompt by copy/paste between CODE tags in your post. You get he CODE tags by clicking on the # button in the tool bar of the post editor.

And while you are at it, please add that same of

/sbin/route -n

Wish I could, problem is that at the moment I do not have the availability of a wired connection. I will try and copy-paste some output via stick, but at the moment I am kind of stuck.

Okay, that was a lot quicker than is suspected. I do not know why, but pinging the dns-server did get a result, but both network-tools and a terminal command for the domain give no result.

wlo1      Link encap:Ethernet  HWaddr 68:94:23:CC:A5:47  
          inet addr:  Bcast:       Mask:
          inet6 addr: fe80::6a94:23ff:fecc:a547/64 Scope:Link
          RX packets:65068 errors:0 dropped:1 overruns:0 frame:0
          TX packets:110 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:6364286 (6.0 Mb)  TX bytes:21476 (20.9 Kb)

wlo1      IEEE 802.11bgn  ESSID:"eduroam"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:13:1A:90:E5:D0   
          Bit Rate=36 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=50/70  Signal level=-60 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:173   Missed beacon:0
ping -c1
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=51 time=10.6 ms

--- ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 10.621/10.621/10.621/0.000 ms

/sbin/route -n
Destination        Gateway               Genmask          Flags    Metric    Ref    Use    Iface                UG       0           0      0        wlo1          U         9           0      0       wlo1

I had thought to see how the routing was organised, but I am sorry to say that I do not have sufficient knowledge of networking to know if something strange is happening.
I am now connected (or not) via an eduroam connection, but I have tried a number of coffeeshops around the University all with the same effect.
NM-tool output gives nothing out of the ordinary. Driver rt2800pci should be fine I think.

Hi, welcome to the openSUSE forums,

My guess is you’re missing the gateway address (i.e. the address of your router as the gateway’s IP). But that’s just a guess, since you don’t show your output.
Furtheron my guess is that you don’t use the Networkmanager? Is that correct?

If you use ‘ifup’ instead of Networkmanager, add your router’s IP as the gateway.

Sorry, I gave the full output of

route -n

, if I run

netstat -(n)r

I get the exact same results

Nope, I run the standard NM, not ifup. Strange thing is that I have run Fedora20 on this machine and had no problem with the wireless. Router’s IP isn’t interesting as a solution as it happens with every Wireless Connection I try.

When you can ping to, you do have Internet connection ) and you have a default gateway functioning.

What I am still missing is what happens that make you say that you can not connect to the Internet (which btw you just proved as being not true, that is why we are non-believers).

Maybe you try to connect to a host.domainname?
When that is the case, it could be that your system can not resolve host domain name into IP addresses. To see what your DNS server is:

grep -v '^#' /etc/resolv.conf

But again, I am guessing and guessing. You did not specify what you did, what you expected to happen and what happened instead (that are the three parts of a good problem description) that you shortened to the simple cry “no internet”. It is only a little bit less usefull then the infamous “it does note work”.

My apologies but I did not just cry ‘No Internet’.
As I stated, I walked through most of the steps that I could think of and couldn’t find anything logically wrong.
When I got a ping response on the DNS I also had a look in firewall and browser settings, however:

Firefox can’t connect to any websites
Can’t update the system, when it tries to do so it gives a “can’t connect” message
Again, I am on my Uni’s eduroam (Groningen by the way @Knurpht) so I can’t see if I can create a connection with other devices on a network
However, this morning during install on my home network, I got the same results.
Only thing that proved to me that there was any kind of connection (apart from the applet) is the fact that when I ping directly to the dns I get a response, however when I want to ping a domain it says that it can’t find the domain.
This would imply a strange DNS mistake, but I already added the google dns settings just to be safe.

So I have no idea what kind of output is handy at the moment or what is going wrong.

From your first post:

however I can not connect to the net.

As I guess you only tried a few and not “any”, did you try

I asked you above in post #7.

grep -v '^#' /etc/resolv.conf

Gave no output. I have run through a large number of websites from different domains and origins and have tried a number of direct ip addresses, no luck what so ever.
If I edit the resolv.conf and resolv.conf.netconfig to add google nameservers (I know it’s not meant to be done manually in that last one’s case) I briefly get access to websites but only for a minute.

Sorry, but it is a bit difficult for me to have a concversation with you. Earlier I asked you to

show the prompt, the command, the output and the next prompt b

When you would have done that, we would have seen that that gave no output. No need to tell us your conclusion, just do it and show it.

Also I can not realy read from the above if you tried the URL in Firefox and what happened there (this is of course no computer output, but a precise explanation is wanted).

We try to help more people on more problems in the amount of spare time we have. Thus efficiency is something we like.

My conclusion is that you have no DNS server configured at all.

Please add the following line at the end of /etc/resolv.conf:


and then try (and post complete!)

ping -c1