Connected to network but not recieving any data from the network...?

Hello all,

Been reading around trying to figure out what’s wrong with my machine. Im connected to a network (have tried multiple and its all behaving the same). The computer is connected to the network but not receiving any data whatsoever.

Not super sure what’s going on, looked on

ip link

to check if everything was up and there is a device I don’t recognize (lo) that’s there. Was that there by default, I read that’s a loopback device?

Any help towards fixing this issue would be great, I’d rather fix it instead of just doing a re-install.

Thanks in advance.

Hi, welcome to these forums.

What would help is if you posted the actual output of commands, between CODE tags, the # in the layout ribbon.


sudo rm /etc/resolv.conf && sudo rcnetwork restart


Yes! Thank you so much for that.

Could you explain what was going wrong? What does resolv.conf have to do with the networking?

/etc/resolv.conf contains the DNS entries. Sometime it happens that it doesn’t get configured correctly, probably to timing issues, Removing it and restarting the networking reconfigures that, recreates the file.
No idea what has caused this issue, seen it more often though ( and not just on openSUSE ). From the rep. comment I get that this solved your issues ?

So it briefly worked, I restarted the PC and now whenever I try and connect to a network using network manager it remains stuck on “Configuring Interface”… I’m not super sure what’s going on :’( I thought it had been fixed but I think something else broke in the process…?

What does the following report?


See below:

wlp3s0: disconnected
        "Intel Centrino Advanced-N 6205 [Taylor Peak] (Centrino Advanced-N 6205 (802.11a/b/g/n))"
        wifi (iwlwifi), 12:EA:16:C0:E7:AF, autoconnect, hw, mtu 1500

enp0s25: unavailable
        "Intel 82579LM Gigabit (Lewisville)"
        ethernet (e1000e), 3C:97:0E:B4:11:EA, hw, mtu 1500

lo: unmanaged
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

Use "nmcli device show" to get complete information about known devices and
"nmcli connection show" to get an overview on active connection profiles.

Consult nmcli(1) and nmcli-examples(5) manual pages for complete usage details.

A little update, sometimes it does not want to connect and go past the configuring interface, and when rebooting and trying again it sometimes manages to connect… Why would it be doing this? It’s the same connection and its relatively annoying needing to restart over and over to be able to get the network adapter working :confused:

This appears to be a different issue to what was initially reported (although it may have been a symptom perhaps). Are you getting reasonable signal levels? Interference issues?

You could try a scan like this…

sudo iw dev wlp3s0 scan

and report back with the output.

You can examine the NetworkManager logging while attempting to connect. Open a terminal

sudo journalctl -fu NetworkManager

and then try starting the wireless network connection. Capture the output.

That’s your problem right there, and supported by your subsequent posts…

The loopback interface (lo) is an interface that exists on practically every machine because that is typically the interface that is used when a machine wants to connect to itself (hence, “looping” back to itself). Because it only enables the machine to connect to itself, this interface isn’t useful for connecting to other machines.

Your command returns any interfaces which are active, and nothing else displays so of course without a working external network interface you can’t connect to anything else.

Your nmcli result also is informative…

  • You’re using Network Manager, does that mean that you are trying to connect to wireless networks?
  • Your machine has detected a wireless device on your machine and set up a network interface to use it as much as possible, but that is all. Wireless connections typically require wireless authentication which is more than what is required for other types of network connections.

Assuming that you’re trying to connect to a wireless network,

  • You have to open Network Manager. On different Desktops, this is done differently, but on most you will see at least one if not two network icons in the main taskbar/panel, on most Desktops the default is along the bottom edge of your display. If you see two icons, one will display the network activity and the other is your Network Manager. Rt-click on either, you’re looking for something that says “Network Connections” – Select it and click so that opens.
  • Once you have “Network Connections” open, you will need to click on a button to “Create a New Connection” (may be slightly different, but same meaning)
  • Select the type of connection you want to create, generally it will be something like “Wireless” or “WPA”
  • Fill out the fields as required, some important ones are
    SSID - The name of the wireless access point you’re connecting to. Often a scanner is available which will detect active APs in the area, and you can just select the correct AP
    Password - The WPA password required for your AP.

Assuming your AP provides DHCP services(Most home APs provide this) and your Network Manager is set up to be a DHCP client(typically the default), when you save your settings, your machine should immediately connect.

As you connect to different wireless networks, you’ll have to create a new network connection for each following the same procedure.