Connect Using MobaXTerm

I’m running OpenSuse Leap 15.1 on my virtual box. I’ve ran command:
sudo zypper install openssh

Then get the IP address using command “ifconfig” but I’m still not able to ssh to the OpenSuse Terminal using MobaXterm.

I did this in the past with Ubuntu without any issue. I just need to run the command:
sudo apt-get install openssh-server

Then I connect to MobaXTerm. Very simple. Why doesn’t it work with OpenSuse? What am I doing wrong?

I just ran command on my OpenSuse Terminal

systemctl enable sshd.service
systemctl start sshd.service

But I’m still NOT able to ssh to my OpenSuse Terminal using MobaXTerm.

If this is a brand new, unmodified openSUSE running in a virtual machine,
You might find it easier to simply set this machine aside and instead build a new virtual machine.

During the install,
In the “Installation Summary” screen which lists everything you intend to install before actually doing the installation,
Scroll down to the bottom.
You’ll find options to install, enable and set up your SSH automatically as part of the installation, including creating a certificate for authentication (so you don’t have to submit username/password on every connection).
The following is a screenshot of what you want to modify…
https://slides.com/tonysu/opensuse#/11

The time you spend to create a new VM with SSH enabled can easily require less time, eliminates User Setup error and with fewer headaches than setting up manually after install like what you are doing.

But,
If you wish to continue with the current machine, the following is the LEAP documentation for setting up SSH, SCP, SFTP, etc.

https://doc.opensuse.org/documentation/leap/security/html/book.security/cha.ssh.html

Whatever you decide to do,
If you run into a problem, post again with details about your issue.

TSU

1 Like

Hi
Did you check the sshd port is open in the Firewall, you can do this via YaST.