connect loptop to projector

hi guys,

i need to connect my loptop Vaio F116FG to projector with VGA cable.now when i connect them in suse,projector doesnt show loptop image,and loptop doesnt know projector.(in windows 7 its work fine)

what should i do?

My Graphic card is Nvidia G330M,and its driver is installed

Thanks

Hi, can you be a bit more precise on your system:

  • what precise version of OpenSUSE are you using
  • what kind of desktop are you using and what version
  • what exact version of driver are you using
  • do you have a function key on it to switch between the normal screen view and projection mode?

A cheap workaround that is sometimes working: switch on the projector first with the laptop attached. Then boot up the laptop.
Check also if there is a manual channel switch for the projector. In this case it will be probably organized in a loop way:

  • one pressure channel one
  • second pressure channel two
  • third pressure video

this or similar. Such a routine might be detected by some proprietary protocol in Win7 but not in Linux. So then you will do have to press the button by hand.
Good luck.

thanks for your answer,

this is my system information:

Linux 2.6.34-12-desktop i686

System: openSUSE 11.3 (i586)

KDE: 4.4.4 (KDE 4.4.4) “release 2”

3D driver: NVIDIA 256.53

i have function key to switch(it works in win7,here doesnt work)

Thanks,so much

I have found in the past that occastionally openSUSE does not detect the projector unless you reboot - sometimes the function key combination which some laptops have may also solve the problem. Having installed 11.4, these problems appear to have disappeared. So try rebooting/using function keys and if that doesn’t work try upgrading.

HI,
Do you use the application: nvidia-settings?

when i installes nvidia driver,it installed too

but i didnt use it

thanks,i rebooted but it didnt changed.what do you mean reboot using Function keys?how is it?

Sounds as it is is a video driver problem; on my Acer Fn-F5 switches dual monitors on or off.

Use nvidia-settings!! this is the application you need to activate twin view, extended desktop etc etc

Hi, I’m not trying to hijack this thread, but I was wondering how to make these settings made using nvidia-settings permanent? I have to setup dual monitor settings each time I reboot, which is pretty inconvenient. (This is probably also relevant for the OP that’s why I felt free to ask here)

HI,
to make it permanent:

  • launch nivdia-settings in root from a terminal or ALT+F2 “kdesu nvidia-settings”
    Then make your set up and click " save to X configuration file" which should be “/etc/X11/xorg.conf”

then the same settings will be applied at each reboot.

That worked! For some reason my font looked much smaller (same font settings) so I had to readjust those, but now it works great. Thanks so much! :slight_smile:

you’re welcome…sharing experience!