I was tracking some traffic through wireshark and I came to:

I also found that the system was connecting to

I have not installed nor ever used nor ever registered for the mozilla’s vpn. BTW, I wasn’t using firefox at the time (although it is installed on my system)

How do I disable these?

Thank you

You can disable the connectivity check by:

Create a file named “50-disable-connectivity-check.conf” in “/etc/NetworkManager/conf.d” with the following content:


Don’t know about vpn.mozilla .org - maybe an entry in “/etc/hosts” such as “” ?

I’m pretty sure that’s only used to check whether you have a usable internet connection.

I also found that the system was connecting to

If you had a browser open – any browser – there’s a possibility that the connection is due to an advertisement being shown in that browser. is there because firefox is using https for DNS

to get rid of it - go into firefox and disable https for DNS.

Look like Mozilla uses it to retrieve some content blocking lists…

Thanks for the info

Where is this for 15.5, I have no folder under /etc/NetworkManager/ called conf.d?

@nasheayahu This thread is more than 2 years old. I think you would have better luck starting a new thread with what you want to do. For one thing, I do not think it is a great idea to disable that connectivity check, might have unintended consequences. It is doing no harm.