Conky Problems

Hi, guys.
Trying to use conky here.
After installing conky and conky-manager and trying to enable some conky from manager I receive this…
https://drive.google.com/file/d/0B-cox3mU2U_wUzUxMTI3ZXBrSE0/view?usp=sharing

Any suggestion what it could be?

Hi
With conky 1.x the configuration files have changed to being lua based and need converting, also (see this thread http://forums.opensuse.org/showthread.php?t=516692) it would appear if the configs are missing the following you see that effect;


own_window_argb_visual = true,
own_window_argb_value = 0,
own_window_colour = 'black',

Thanks for response.

It seems that I tryed everything from that thread and its still the same…

conky.config = {-- UBUNTU-CONKY
-- A comprehensive conky script, configured for use on
-- Ubuntu / Debian Gnome, without the need for any external scripts.


-- Based on conky-jc and the default .conkyrc.
-- INCLUDES:
-- - tail of /var/log/messages ############################(TRY USING TAIL VARIABLE INSTEAD OF SHELL TAIL)############################################# ######
-- - netstat connections to your computer


-- -- Pengo (conky@pengo.us)


--GENERAL STUFF
    double_buffer = true,
    use_spacer = 'none',
    update_interval = 2.0,
--background yes
--out_to_console no
--total_run_times 0
--${execi 30 wmctrl -a conky}


--WINDOW STUFF
    own_window = true,
    own_window_type = 'normal',--override
    own_window_transparent = false,
    
    own_window_argb_visual = true,
	own_window_argb_value = 0,
	own_window_colour = 'black',


    own_window_hints = 'undecorated,below,sticky,skip_taskbar,skip_pager',
--own_window_hints skip_taskbar,skip_pager
--own_window skip_taskbar


--COLOR STUFF
    own_window_colour = 'brown',
    default_color = 'white',--Text #Default colors and also border colors, grey90 == #e5e5e5
    default_shade_color = 'black',
    default_outline_color = 'black',


--TEXT AREA STUFF
--minimum_size 250 5 #Minimum size of text area
    minimum_width = 320, minimum_height = 5,


--BORDER STUFF
    draw_outline = false,
    draw_borders = false,
    draw_shades = false,
    stippled_borders = 3,
    border_width = 10,


--FONT STUFF
--font -*-newspaper-*-*-*-*-*-*-*-*-*-*-*-*
    use_xft = true,
    font = 'Bitstream Vera Sans Mono:size=8',
    xftalpha = 0.8,
    uppercase = false,


--TEXT ALIGNMENT STUFF
--alignment top_left
    alignment = 'top_right',
--alignment bottom_left
--alignment bottom_right
    gap_x = 10,--Horizontal Gap between borders of screen and text
    gap_y = 10,--10 #Vertical Gap between borders of screen and text




--TEXT TO BE DISPLAYED IN CONKY WINDOW
--################################################# ################


};


conky.text = 
$color
${color magenta}SYSTEM ${hr 2}$color
$nodename $sysname $kernel on $machine
Maximum Operating Temperature: CPU 95 C, HDD 60 C
CPU Temp: ${acpitemp} #HDD Temp: ${hddtemp} 
Load: ${loadavg}


${color yellow}Core 0: ${hr 2}$color
Freq: ${freq 1}MHz
${cpubar cpu1 8,70}
${cpugraph cpu1 000000 ffffff}
${color red}Core 1: ${hr 2}$color
Freq: ${freq 2}MHz
${cpubar cpu2 8,70}
${cpugraph cpu2 000000 ffffff}
${color yellow}Core 2: ${hr 2}$color
Freq: ${freq 3}MHz
${cpubar cpu3 8,70}
${cpugraph cpu3 000000 ffffff}
${color red}Core 3: ${hr 2}$color
Freq: ${freq 4}MHz
${cpubar cpu4 8,70}
${cpugraph cpu4 000000 ffffff}
NAME             PID     CPU%   MEM%
${top name 1} ${top pid 1} ${top cpu 1} ${top mem 1}
${top name 2} ${top pid 2} ${top cpu 2} ${top mem 2}
${top name 3} ${top pid 3} ${top cpu 3} ${top mem 3}
${top name 4} ${top pid 4} ${top cpu 4} ${top mem 4}
${top name 5} ${top pid 5} ${top cpu 5} ${top mem 5}
${top name 6} ${top pid 6} ${top cpu 6} ${top mem 6}
${top name 7} ${top pid 7} ${top cpu 7} ${top mem 7}
${top name 8} ${top pid 8} ${top cpu 8} ${top mem 8}
${top name 9} ${top pid 9} ${top cpu 9} ${top mem 9}
${top name 10} ${top pid 10} ${top cpu 10} ${top mem 10}


${color yellow}MEMORY / DISK ${hr 2}$color
RAM: $memperc% ${membar 6}$color
Swap: $swapperc% ${swapbar 6}$color


${color yellow}NETWORK (${addr wlan0}) ${hr 2}$color
Down: $color${downspeed wlan0}                  Up: ${upspeed wlan0}
${downspeedgraph wlan0 25,140 000000 ff0000} ${alignr}${upspeedgraph wlan0 25,140 000000 00ff00}$color
Total: ${totaldown wlan0}                Total: ${totalup wlan0} #${alignr}


Inbound: ${tcp_portmon 1 32767 count}  Outbound: ${tcp_portmon 32768 61000 count}${alignr}  Total:${tcp_portmon 1 65535 count}


#${color yellow}LOGGING ${hr 2}$color
#${execi 30 tail -n3 /var/log/messages | fold -w50}


#wlan0 eth0 wlan1 eth1


]];

Hi
Under --COLOR STUFF you have a duplicate entry for own_window_color

Still the same.

On Fri 25 Mar 2016 06:56:02 PM CDT, galileo13 wrote:

Still the same.

Hi
So in your example screen cap (miui) I converted and fixed up the three
entries indicated and it works fine via conky-manager. In your config
example you posted, again changed those three things and all is good?

http://thumbnails114.imagebam.com/47381/9e30de473809170.jpg](ImageBam)

Maybe a bit more detail on the actual issue, start the config from the
command line, does it show errors?


conky -c /path/to/someconfig


Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 SP1|GNOME 3.10.4|3.12.53-60.30-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Thanks a lot!

I did not know that I needed to change and convert theme config file also!
Now its working!

Yep…here again.

Now with another problem.
When I wont use this http://www.noobslab.com/2013/03/install-malice-tab-conky-in-ubuntulinux.html or any other conky that **requere ‘cairo’
**I receive this error:


conky: bargraph_small.lua:87: module 'cairo' not found:
	no field package.preload'cairo']
	no file './cairo.lua'
	no file '/usr/local/share/lua/5.1/cairo.lua'
	no file '/usr/local/share/lua/5.1/cairo/init.lua'
	no file '/usr/local/lib/lua/5.1/cairo.lua'
	no file '/usr/local/lib/lua/5.1/cairo/init.lua'
	no file '/usr/share/lua/5.1/cairo.lua'
	no file '/usr/share/lua/5.1/cairo/init.lua'
	no file './cairo.so'
	no file '/usr/local/lib/lua/5.1/cairo.so'
	no file '/usr/lib64/lua/5.1/cairo.so'
	no file '/usr/local/lib/lua/5.1/loadall.so'

It seems that I have coiro installed:


igor@phoenix:~/.conky/malice-tab-noobslab-u/.conky/Malice-Tab/scripts> whereis cairo
cairo: /usr/lib64/cairo /usr/include/cairo

But it wont work. Or, more probably, I am doing something wrong.

On Sat 26 Mar 2016 02:06:02 AM CDT, galileo13 wrote:

Yep…here again.

Now with another problem.
When I wont use this Install Malice-Tab Conky in Ubuntu/Linux Mint/Debian/and Ubuntu derivatives - NoobsLab | Eye on Digital World or any other conky that
*requere ‘cairo’
*I receive this error:

Code:

conky: bargraph_small.lua:87: module ‘cairo’ not found:
no field package.preload’cairo’]
no file ‘./cairo.lua’
no file ‘/usr/local/share/lua/5.1/cairo.lua’
no file ‘/usr/local/share/lua/5.1/cairo/init.lua’
no file ‘/usr/local/lib/lua/5.1/cairo.lua’
no file ‘/usr/local/lib/lua/5.1/cairo/init.lua’
no file ‘/usr/share/lua/5.1/cairo.lua’
no file ‘/usr/share/lua/5.1/cairo/init.lua’
no file ‘./cairo.so’
no file ‘/usr/local/lib/lua/5.1/cairo.so’
no file ‘/usr/lib64/lua/5.1/cairo.so’
no file ‘/usr/local/lib/lua/5.1/loadall.so’


It seems that I have coiro installed:

Code:

igor@phoenix:~/.conky/malice-tab-noobslab-u/.conky/Malice-Tab/scripts>
whereis cairo cairo: /usr/lib64/cairo /usr/include/cairo


But it wont work. Or, more probably, I am doing something wrong.

Hi
Is lua51 installed?


Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 SP1|GNOME 3.10.4|3.12.53-60.30-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Aham


'lua51' is already installed.
No update candidate for 'lua51-5.1.5-11.4.x86_64'. The highest available version is already installed.
Resolving package dependencies...

Hi
I just tried here and don’t get the error, what about imlib2-loaders is that installed?

Hm…its installed also. Strange…

Its okay. many thanks for your help anyway.