Conky graphs don't work when swallowed in pager?

I’ve been using conky system monitor for some years now. I have it set up to be swallowed into the pager by the window manager (fvwm2) on startup, like this:

*FvwmButtons: (2x2, Frame 0, Swallow(UseOld,NoHints,Respawn) "Conky" `Exec exec /usr/bin/conky`)

This worked fine in previous OpenSuSE versions, but in my new LEAP 15 install, the cpugraph is invisible. (Actually if I modify .conkyrc and save it, the ftame will appear until the next update interval, then disappear.) However, if I change the .conkyrc alignment variable from ‘none’ to say ‘top_right’ so that conky draws its window on the root window, the cpugraph* works properly.

Can anyone explain what’s happening & how to fix it, or even suggest a better place to look for help? There doesn’t seem to be a user forum for conky that I can find.

*And other conky graphs that I’ve tried - it’s not something peculiar to cpugraph.

Here’s the .conkyrc file that I use:


conky.config =  
{   
  alignment = 'none',  
  background = false,
  border_width = 1,   
  cpu_avg_samples = 2,   
  default_color = 'white',   
  default_outline_color = 'white',   
  default_shade_color = 'white',   
  draw_borders = false,   
  draw_graph_borders = true,   
  draw_outline = false,   
  draw_shades = false,   
  use_xft = true,   
  font = 'DejaVu Sans Mono:size=10',   
  minimum_height = 5,   
  minimum_width = 5,   
  net_avg_samples = 2,   
  no_buffers = true,   
  out_to_console = false,   
  out_to_ncurses = false,   
  out_to_stderr = false,   
  extra_newline = false,   
  own_window = true,   
  own_window_class = 'Conky',   
  own_window_type = 'normal',   
  double_buffer = true,   
  stippled_borders = 0,   
  update_interval = 5.0,   
  uppercase = false,   
  use_spacer = 'none',   
  show_graph_scale = false,   
  show_graph_range = false 
}  

conky.text = 
${color white}$nodename: ${time %b %d  %k:%M:%S}  $hr 
${color white}CPU:${color red} ${cpu}% ${color green}$freq_g GHz $color 
${color white}FAN: ${color green}${ibm_fan}$color 
 ${color lightgrey} CPU 0: (${cpu cpu1}%) ${exec sensors -f|grep "Core 0" |awk -f conky_get_temp}  
${color lightgrey} CPU 1: (${cpu cpu2}%) ${exec sensors -f|grep "Core 1" |awk -f conky_get_temp} 
${color grey}CPU Usage:$color $cpu% ${cpubar 4} 
${color cyan}${cpugraph 50,170 555500 00FFFF} 
]]

Hi
I use conky in Gnome, from memory the argb and hint options where the ones added for things disappearing, here is what I run;


conky.config = {
   own_window = true,
   own_window_type = 'normal',
   own_window_transparent = false,
   own_window_hints = 'undecorated,sticky,below,skip_taskbar,skip_pager',
   own_window_colour = 'black',
   own_window_class = 'Conky',
   own_window_title = 'Conky Network',
   own_window_argb_visual = true,
   own_window_argb_value = 0,
   double_buffer = true,
   background = true,
   draw_borders = false,
   draw_outline = false,
   minimum_width = 320, minimum_height = 5,
   maximum_width = 320,
   gap_x = 1470,
   gap_y = 20,
   font = 'Cantarell:size=10',
   default_color = '#DCDCDC',
   color0 = '#1793d0',
   color2 = 'green',
   color3 = '#FFFF00',
   color4 = '#FF6400',
   color5 = '#FF0000',
   use_xft = true,
   xftalpha = 0.8,
   override_utf8_locale = true,
   draw_shades = false,
   default_shade_color = 'black',
   draw_outline = false,
   uppercase = false,
}

Doesn’t seem to work for me. If I put that config info in mine,the cpugraph & coubar work fine, but the display appears on the root window instead of being swallowed, If I add “alignment = ‘none’”, it gets swallowed properly, but the graphs disappear.

Hi
What about top_left for alignment?

Have a read here: https://fvwmforums.org/phpBB3/viewtopic.php?t=767

That works! It seems really wierd, though: the other alignments I tried (other than ‘none’) just made the entire conky output display on the root window instead of in the pager, I wonder why this should be different? And why it’s not in the conky man page?

Thanks!