conky error while loading shared libraries

Something’s clearly gone awry here.

I’ve been unable to run conky since I upgraded from Leap 42.3 to Leap 15.

Running it from a terminal gives me

conky: error while loading shared libraries: cannot open shared object file: No such file or directory

ldd points out that conky also needs which is also, unsurprisingly, not present.

I do have more recent version of both libraries: and

How would I persuade conky to use the library versions I’ve got, instead of clinging to the past?

Install a version that’s actually built for Leap 15.0.
The one you try to run is for Leap 42.3…

Really? Then my repository information must be really screwed up. Or the 15.0 repository has 42.3 packages in it.

zypper info conky
Loading repository data...
Reading installed packages...

Information for package conky:
Repository     : openSUSE-leap/15.0-Oss    
Name           : conky                     
Version        : 1.10.6-lp150.1.2          
Arch           : x86_64                    
Vendor         : openSUSE                  
Installed Size : 1.1 MiB                   
Installed      : Yes                                                                                                    
Status         : up-to-date                                                                                             
Source package : conky-1.10.6-lp150.1.2.src
Summary        : Lightweight System Monitor
Description    :                           
    Conky is an advanced, highly configurable system monitor for X.

    This package is built with support for:

    - xmms2

Or am I missing something here?

Repository     : openSUSE-leap/15.0-Oss

This shows you the name the repository has on your system. But that is only a name. I admit that in most cases those names are hinting correctly to what the repository is, but certainly in this case you should look at what it really is. E.g.

zypper lr -d | grep '15.0-Oss'
zypper lr -d | grep '15.0-Oss'
11 | repo-oss                   | openSUSE-leap/15.0-Oss                           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |

I’m tempted to download the source rpm and rebuild it locally. Worth a try, or is there anything else you’d try first?

A general FYI -
The last submit to the Conky project was in 2015.
Doesn’t necessarily mean it won’t compile or wouldn’t otherwise work…
And Conky as been in a half-alive state for many years before then


Uh… As it says on the page you linked:

Development has moved to GitHub at

Latest submit was a mere three days ago. (The 1.10.6 release in Leap 15 is from the end of 2016–maybe we could update to 1.10.8, released in February of this year?)

Okay, something is clearly out of whack here.

Rebuilding from the source rpm is failing. There are a slew of warnings during compilation, which are hiding the actual error that triggers

Bad exit status from /var/tmp/rpm-tmp.o1CJtN (%build)

Installing the version from pacman (which is 1.10.8) gave me the same error about the missing libraries.

Rebuilding the pacman source rpm succeeds, but the resulting binary has the same missing library problem.

Building from a 1.10.8 tar downloaded from the GitHub site linked above gets me a functional binary. Which is great. I can run conky. But since it was built using the defaults, it’s probably missing some of the optional functionality; presumably that functionality includes whatever is looking for those libraries in the openSUSE and pacman builds. Not a problem as long as I never need that functionality.

I can’t be the only person running Leap 15.0 who uses Conky, so there must be something hosed on my system. Any suggestions on how to identify and resolve the problem?

Problem solved, I think.

lddtree pinpointed the dependency on the old libraries to libical.

A little digging turned up an old installation of libical in /usr/local. I deleted that and reinstalled the Leap 15.0 version of conky, and it’s working.

Darned if I know when I installed libical myself, but I must have. Stupid me.