Confusing message from Apache2 about mod_ssl

opensuse V11.3
linux 2.6.34.7-0.7-desktop x86_64
Apache/2.2.15 (Linux/SUSE) PHP/5.3.3 mod_ssl/2.2.15 OpenSSL/1.0.0

The “SSL” flag is specified in </etc/sysconfig/apache2>.

I cannot get mod_ssl to load normally. In </etc/sysconfig/apache2> is the entry

APACHE_MODULES="authz_host actions alias auth_basic authz_groupfile authn_file authz_user autoindex cgi dir include log_config mime negotiation setenvif status userdir asis imagemap php5 authz_default deflate ssl_module"

Note the “ssl_module” at the end. Despite that, there is no corresponding entry in </etc/apache2/sysconfig/loadmodules.conf>.

mod_ssl does not load. There is no message, error, notice, warning or any other hint of a communication about why is does not load. Not in </var/log/apache2/error_log)>, </var/log/messages>, or any of the site logs. Nothing.

The only way to get mod_ssl loaded is to force it by manually adding

LoadModule ssl_module  /usr/lib64/apache2-prefork/mod_ssl.so

to <httpd.conf>.

Here is the startup text:

Module "ssl_module" is not installed, ignoring.
Check the APACHE_MODULES setting in /etc/sysconfig/apache2.
Syntax OK
Shutting down httpd2 (waiting for all children to terminate)     done
Starting httpd2 (prefork)         done

Here is the startup text WITHOUT the manually added LoadModule entry:

Module "ssl_module" is not installed, ignoring.
Check the APACHE_MODULES setting in /etc/sysconfig/apache2.
[Sat Feb ...] [warn] NameVirtualHost *:443 has no VirtualHosts
Syntax OK
Shutting down httpd2 (waiting for all children to terminate)     done
Starting httpd2 (prefork) [Sat Feb ...] [warn] NameVirtualHost *:443 has no VirtualHosts

The warnings are to be expected since <IfModule mod_ssl.c> is not true.

Where have I gone awry?

Hi
Use YaST->/etc/sysconfig editor, then browse to Network->WWW->Apache2->APACHE_SERVER_FLAGS add SSL here. You might have to bounce the server as well.

That flag is already set.

16329 ?        Ss     0:00 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -DSSL
16330 ?        S      0:00 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -DSSL
etc...

It’s just ssl, not ssl_module, as the comment listing the available modules indicates.

That was it. I am sure that I tried that before and apache failed to even start. Must have been a typo then.