Confused with Rosegarden

Hi,

Last time I tried Rosegarden was around 2005. As I did not have a midi
port from my audio card, I used timidity to provide emulation, like this:


Telcontar:~ # timidity -iA -B2,8 -Os -q0/0 -k0
Requested buffer size 2048, fragment size 1024
ALSA pcm 'default' set buffer size 2048, period size 680 bytes
TiMidity starting in ALSA server mode
Opening sequencer port: 129:0 129:1 129:2 129:3

However, when I do that now I hear nothing from rosegarden.

I don’t see any mention of “timidity” in the entire rosegarden doc
(http://rosegardenmusic.com/wiki/doc:manual-en).

How does one set up a midi emulator now for rosegarden? (A pointer to
the correct docu would be just fine)

(I did hear once a loud “plop” on shutting down rosegarden)


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

On 2013-06-25 13:33, Carlos E. R. wrote:
> Hi,
>
> Last time I tried Rosegarden was around 2005. As I did not have a midi
> port from my audio card, I used timidity to provide emulation, like this:
>
>


> Telcontar:~ # timidity -iA -B2,8 -Os -q0/0 -k0
> Requested buffer size 2048, fragment size 1024
> ALSA pcm 'default' set buffer size 2048, period size 680 bytes
> TiMidity starting in ALSA server mode
> Opening sequencer port: 129:0 129:1 129:2 129:3
> 

However, when I do that now I hear nothing from rosegarden.

Playing directly from timidity works:


cer@Telcontar:~/Music/MyMusic> timidity brahms12.mid
Requested buffer size 32768, fragment size 8192
ALSA pcm 'default' set buffer size 32768, period size 8192 bytes
Playing brahms12.mid
MIDI file: brahms12.mid
Format: 1  Tracks: 17  Divisions: 480
Sequence: brahms12.mid
Instrument: Printer
Track name: flutes
Instrument: Printer
Track name: oboes
....


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Audio software is best run [on linux] with a higher priority and memory locked to avoid swapping out to HDD. If you haven’t already done so, I recommend you
add user account to the “audio” group, and add following lines to /etc/security/limits.conf:

@audio - rtprio 99
@audio - memlock unlimited

You would need that to run Jack sound server for example, which is arguably the best way to run Rosegarden, but not the only way. Jack and PulseAudio clash as sound servers, so you need to either disable P/A or temporarily suspend it in Jack setup (the latter worked for me but only on o’suse 12.3).

Rosegarden requires a sound synthesizer, without one you will have no sound. With most sound cards nowadays that means a software sound synthesizer, and in the past Timidity filled that role but no longer suffices. I use and recommend Qsynth (GUI front-end to lower level dependency fluidsynth) which has audio drivers for both P/A, Jack, and more. Qsynth/fluidsynth converts MIDI data into sound using a SoundFont. You will need to pick up a SoundFont file. Both chosen driver and SoundFont are easily configured in Qsynth’s Setup tabs.

To create, edit, and playback midi files and/or connect a (virtual) midi keyboard, Jack is not required. I just use Rosegarden with Qsynth (from Packman), and PulseAudio.

As additional comment, some recent releases of Rosegarden packaged on openSUSE, have the odd hiccup. For example, it starts the daemon “jackd” which needs to be killed to avoid clashing with P/A. Sometimes it takes several “kills” before it stops re-starting, so double-check that jackd has gone after every attempt before commencing to use Rosegarden functions. IRRC, the version for 12.3 either didn’t start jackd or it was easily killed.

I always start Qsynth before starting Rosegarden.

Post back here if you hit any hiccups. :slight_smile:

On 2013-06-25 14:46, consused wrote:

> You would need that to run Jack sound server for example, which is the
> best way to run Rosegarden, but not the only way. Jack and PulseAudio
> clash as sound servers, so you need to either disable P/A or temporarily
> suspend it in Jack setup (the latter worked for me but only on o’suse
> 12.3).

My system uses pulse and I can not change that. I don’t think I can even
install Jack, it would corrupt everything else. I tried that time ago
and it was a nightmare.

> Rosegarden requires a sound synthesizer, without one you will have no
> sound. With most cards nowadays that means a software sound synthesizer,
> and in the past Timidity filled that role but no longer suffices.

Why?

Timidity file.mid plays just fine.

> I use
> and recommend Qsynth (GUI front-end to lower level dependency
> fluidsynth)

No, yast does not select fluidsynth when I install Qsynth. It complains
on startup about Jack, even after I tell it to use Pulse. So I make sure
again that “Qsynth” output says “pulseaudio”, restart it, no complains.

However, I hear nothing. Pulse lists fluidsynth output. I see no “test”
option in qsynth.

> which has audio drivers for both P/A, Jack, and more.
> Qsynth/fluidsynth converts MIDI data into sound using a SoundFont. You
> will need to pick up a SoundFont file. Both chosen driver and SoundFont
> are easily configured in Qsynth’s Setup tabs.

Where do I get those soundfonts from?

> To just play midi files or connect a (virtual) midi keyboard, Jack is
> not required. I just use Rosegarden with Qsynth, and PulseAudio.

The only method that works now is tell rosegarden to export to midi
file, then play it directly from timidity


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

On 2013-06-25 15:36, consused wrote:
>
> As an additional comment, some recent releases of Rosegarden packaged on
> openSUSE, have the odd hiccup. For example, it starts the daemon “jackd”
> which needs to be killed to avoid clashing with P/A. Sometimes it takes
> several “kills” before it stops re-starting, so double-check that jackd
> has gone after every attempt before commencing to use Rosegarden
> functions. IRRC, the version for 12.3 either didn’t start jackd or it
> was easily killed.

No, jack is not running.


cer@Telcontar:~> ps afxu | grep jack
cer      29854  0.0  0.0   7088   856 pts/9    S+   15:49   0:00
|       \_ grep --color=auto jack
cer@Telcontar:~>

It tries, though:


ATTENTION: The playback device "hw:0" is already in use. The following
applications  are using your soundcard(s) so you should  check them and
stop them as necessary before  trying to start JACK again:

pulseaudio (process ID 4476)

JackTemporaryException : now quits...
Cannot initialize driver
JackServer::Open() failed with -1
Failed to open server
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket


I have uninstalled jack, no difference.

> Post back here if you hit any hiccups. :slight_smile:

No sound at all from rosegarden…


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Maybe that’s a choice you made, and further discussion would require more detail…

I can’t imagine why a linux sound server should corrupt anything. What’s “everything else”…

Why what?

Qsynth requires “libfluidsynth”, maybe its installed by default but I don’t recall.

There have been several recent updates to qsynth since I last used it. In any case, mine was set for jack from my last test. It also complained without jack running. Changing driver to P/A also stopped the problem here.

Where do I get those soundfonts from?

I searched the internet years ago, and also had an old 8MB soundfont2 instrument bank (file 8mbgmsfx.sf2) left over from a Creative Labs AWE64G sound card (circa 1998), but nowadays you can get much better quality although the file will approach 150MB or more. Look out for a .sf2 file with “Fluid R3 GM” in the name (with/out the spaces). I noticed that Arch Linux now provides the Fluid R3 instrument bank for their users. I suspect you can also pay good money for the best professional .sf2 instrunents.

No sound without a working softsynth, and no sound from Qsynth without specifying a valid soundfont2 file in the appropriate Setup tab. :wink:

On 2013-06-25 18:06, consused wrote:
>
> robin_listas;2567185 Wrote:
>>
>> My system uses pulse and I can not change that.
> Maybe that’s a choice you made, and further discussion would require
> more detail…

It is the system choice, not mine. Gnome and XFCE use pulse. All my
multimedia tools use Pulse. I tried once to do without and everything
sound related broke. That’s not something I can change on a minute. If I
absolutely need to, I would have to do it on a virtual machine to run
rosegarden inside.

> robin_listas Wrote:
>> I don’t think I can even install Jack, it would corrupt everything else.
>>
> I can’t imagine why a linux sound server should corrupt anything.
> What’s “everything else”…

Everything that needs pulse in my system. I tried once to remove pulse
for a test, and it took me a lot of effort to undo and get sound working
again, with Pulse.

> robin_listas Wrote:
>> Why?
> Why what?

Why can not I use timidity? Why do you say I need something “more
powerful”, but which does not work? qsynth needs fonts, I have none.
Timidity works fine without me bringing any font.

> robin_listas Wrote:
>> No, yast does not select fluidsynth when I install Qsynth. It complains
>> on startup about Jack, even after I tell it to use Pulse. So I make
>> sure
>> again that “Qsynth” output says “pulseaudio”, restart it, no complains.
> Qsynth requires “libfluidsynth”, maybe its installed by default but I
> don’t recall.

It is not installed in my system at all, and it is not a dependency.
What is installed is “libfluidsynth1”.

> There have been several recent updates to qsynth since I last used it.
> In any case, mine was set for jack from my last test. It also complained
> without jack running. Changing driver to P/A also stopped the problem
> here.
>
>> Where do I get those soundfonts from?

> I searched the internet years ago, and also had an old 8MB soundfont2
> instrument bank (file 8mbgmsfx.sf2) left over from a Creative Labs
> AWE64G sound card (circa 1998), but nowadays you can get much better
> quality although the file will approach 150MB or more. Look out for a
> .sf2 file with “Fluid R3 GM” in the name (with/out the spaces). I
> noticed that Arch Linux now provides the Fluid R3 instrument bank for
> their users. I suspect you can also pay good money for the best
> professional .sf2 instrunents.

I don’t need anything professional, I just need anything that plays,
whatever it is. I expected the software to come complete and play.
Timidity plays, I don’t see why qsynth doesn’t if it is more powerful.

Look, I know nothing of rosegarden, or midi. I just want it to play midi
files, that’s all. I don’t care for fancy fonts.

I want a guide for dummies. Start this command with this command line,
this other, and go. And it must not disable Pulse, or the rest of my
system breaks.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

I am using xfce also and I can disable and remove pulse and use alsa without a problem.
There must be something wrong somewhere.

On 2013-06-25 13:33, Carlos E. R. wrote:

> However, when I do that now I hear nothing from rosegarden.
>
> I don’t see any mention of “timidity” in the entire rosegarden doc
> (http://rosegardenmusic.com/wiki/doc:manual-en).
>
>
> How does one set up a midi emulator now for rosegarden? (A pointer to
> the correct docu would be just fine)

Same question in Ubuntu forum.


http://ubuntuforums.org/showthread.php?t=1700943

It points to a photo, but it is not visible unless you log in :-/

I got rosegarden playing with timidity. You have to do something with
the keyboard mentioned in that ubuntu forum, but I don’t know exactly
what. I hear the music, anyway.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

On 2013-06-25 19:36, conram wrote:

> I am using xfce also and I can disable and remove pulse and use alsa
> without a problem.
> There must be something wrong somewhere.

As I said, I just got rosegarden running with timidity with no changes
to my audio config. Granted, I only get a piano; dunno because there is
something wrong or because it is this way.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

It is not installed in my system at all, and it is not a dependency.
What is installed is “libfluidsynth1”.

libfluidsynth1 is what you need

Some soundfonts can be found here:
SoundFont – FluidSynth
HammerSound
Free Soundfonts - SF2 Files

Soundfonts marked as GM (General Midi, it’s a standard) will contain a set of instruments which is perhaps what you want. Otherwise you may download one soundfont each for the various instruments which you according to the partitur wish to use.
You could also install soundfonts from YaST, ‘GeneralUser’ from Packman or ‘fluid-soundfont-gm’ from multimedia:apps, both are GM.

Timidity also takes a sound-font.

You could try xsynth-dssi. It is quite simple but gives you some instruments to choose from and it does not require you to set up a sound-font. To assign it to a Rosegarden track load it from the ‘Synth plugins’ list.
This is possibly the easiest way to start using Rosegarden, in my view.

I can understand your reluctance, as I too prefer to avoid disabling P/A (KDE). However others do it successfully as per @conram’s post. It depends on one’s priorities and circumstances.

> robin_listas Wrote:
>> Why?
> Why what?
Why can not I use timidity? Why do you say I need something “more
powerful”, but which does not work? qsynth needs fonts, I have none.
Timidity works fine without me bringing any font.

Using Timidity with Rosegarden was never fully supported by the developers. When it worked it avoided using Jack. Neither was designed to be used by the other. Jack and the apps that are designed to use it tend to be aimed at pro audio. Rosegarden does not include a softsynth by design. If you want to argue, I suggest you take it up with their developers (others have tried it before you, and failed).

I don’t need anything professional, I just need anything that plays,
whatever it is. I expected the software to come complete and play.
Timidity plays, I don’t see why qsynth doesn’t if it is more powerful.

Look, I know nothing of rosegarden, or midi. I just want it to play midi
files, that’s all. I don’t care for fancy fonts.

I want a guide for dummies. Start this command with this command line,
this other, and go. And it must not disable Pulse, or the rest of my
system breaks.

You chose to use rosegarden and post here on it! For midi file playback only, just use timidity on it’s own. You can even use command line tools to play midi see man page “aplaymidi”.

Want a guide for dummies, google usually works for me. It might be for another distro though.

Need a soundfont? Google for it, since you don’t need anything special.

On 2013-06-25 20:26, F Sauce wrote:
>
>> It is not installed in my system at all, and it is not a dependency.
>> What is installed is “libfluidsynth1”.
> libfluidsynth1 is what you need
>
> Some soundfonts can be found here:
> ‘SoundFont – FluidSynth’
> (http://sourceforge.net/apps/trac/fluidsynth/wiki/SoundFont)
> ‘HammerSound’ (http://www.hammersound.net/)
> ‘Free Soundfonts - SF2 Files’ (http://soundfonts.homemusician.net/)
>
> Soundfonts marked as GM (General Midi, it’s a standard) will contain a
> set of instruments which is perhaps what you want. Otherwise you may
> download one soundfont each for the various instruments which you
> according to the partitur wish to use.
> You could also install soundfonts from YaST, ‘GeneralUser’ from Packman
> or ‘fluid-soundfont-gm’ from multimedia:apps, both are GM.

Aha!

Ok, I installed the one from packman, that’s the easy way (no repo to
add for the moment). Told qsynth to load it, then started rosegarden,
and it plays a midi file of a brahms concerto quite nicely :slight_smile:

Thanks! :slight_smile:

That suffices my simple needs for the moment :slight_smile:

I have some scores from a grand-uncle of mine, and I want to “listen” to
some of them, to find out what he wrote. I can read music scores, but my
ear is too bad to know how it sounds and I can not play any instrument
successfully. So… computer to the rescue :wink:


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Good one:)
Later on you might also try the Fluid sound-font, it’s quite a bit larger but it sounds quite good.

Cheers,
Olav

On 2013-06-25 20:36, F Sauce wrote:

> Timidity also takes a sound-font.

Maybe, but it runs without asking. Maybe just a piano font.

> You could try xsynth-dssi. It is quite simple but gives you some
> instruments to choose from and it does not require you to set up a
> sound-font. To assign it to a Rosegarden track load it from the ‘Synth
> plugins’ list.
> This is possibly the easiest way to start using Rosegarden, in my view.

Huh.

I’m just trying it, but I don’t understand it at all. It appears to want
me to adjust all synthesizer parameters, there are no instruments
defined. :-?


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

On 2013-06-25 21:16, consused wrote:

> Want a guide for dummies, google usually works for me.
>
> Need a soundfont? Google for it, since you don’t need anything special.

F Sauce told me how to get it working, thanks. It is very simple,
really, once told, not as complicated as you make it sound.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

lol! What is so complicated about searching for “soundfonts”? Don’t be so lazy, how do you think others manage to find them.

Unfortunately for me, being first on the scene, your initial post was (deliberately) vague and devoid of any helpful information as to why you needed Rosegarden. After pontificating, you finally owned up to the simplicity of your requirement, which obviously doesn’t need it. :open_mouth: