Conflicts when updating from Leap 42.2 to 42.3

Dear experts,

i ave recently tried to update from Leap 42.2 to 42.3. To do so I changed all repositories to 42.3


# | Alias                     | Name                      | Enabled | GPG Check | Refresh
--+---------------------------+---------------------------+---------+-----------+--------
1 | adobe                     | adobe                     | Yes     | ( p) Yes  | Yes    
2 | download.opensuse.org-oss | Main Repository (OSS)     | Yes     | (r ) Yes  | Yes    
3 | packman                   | packman                   | Yes     | (r ) Yes  | Yes    
4 | repo-update               | openSUSE-Leap-42.3-Update | Yes     | (r ) Yes  | Yes 
 

Subsequently i tried to update via yast, by choosing
software management->package->all packages-> update if newer version available.

Having fired the command i got the following conflict list (see below). I presume that vlc might be a problem, since it is not part of the distribution. However, libreoffice, kdepim4-4.14.10-6.5.1.x86_64 and kaddressbook-17.04.2-1.1.x86_64 seem a bit scary to me.
Therefore, i decided to stop the update and ask the experts here, how to proceed further.

thank you for your help


#### YaST2 conflicts list - generated 2019-01-22 22:39:21 ####

kdepim4-4.14.10-6.5.1.x86_64 requires libgpgme-pthread.so.11()(64bit), but this requirement cannot be provided
deleted providers: libgpgme11-1.6.0-10.5.x86_64
     ] break kdepim4-4.14.10-6.5.1.x86_64 by ignoring some of its dependencies

     ] do not install libgpgme11-1.9.0-1.3.x86_64

    [x] deinstallation of kdepim4-4.14.10-6.5.1.x86_64



libreoffice-base-6.1.3.2-27.4.x86_64 obsoletes libreoffice-base-drivers-mysql provided by libreoffice-base-drivers-mysql-6.0.5.2-24.2.x86_64

     ] Following actions will be done:
do not install libreoffice-base-6.1.3.2-27.4.x86_64
do not install libreoffice-l10n-bg-6.1.3.2-27.4.noarch
do not install libreoffice-l10n-de-6.1.3.2-27.4.noarch
do not install libreoffice-l10n-en-6.1.3.2-27.4.noarch
do not install libreoffice-math-6.1.3.2-27.4.x86_64
do not install libreoffice-pyuno-6.1.3.2-27.4.x86_64
do not install libreoffice-writer-6.1.3.2-27.4.x86_64
do not install libreoffice-writer-extensions-6.1.3.2-27.4.x86_64
do not install libreoffice-filters-optional-6.1.3.2-27.4.x86_64
do not install libreoffice-mailmerge-6.1.3.2-27.4.x86_64
     ] do not install libreoffice-base-drivers-mysql-6.0.5.2-24.2.x86_64



libreoffice-6.1.3.2-27.4.x86_64 requires libreoffice-icon-themes = 6.1.3.2, but this requirement cannot be provided
uninstallable providers: libreoffice-icon-themes-6.1.3.2-27.4.noarch[repo-update]
     ] break libreoffice-6.1.3.2-27.4.x86_64 by ignoring some of its dependencies

     ] do not install libreoffice-icon-theme-breeze-5.4.5.1-15.1.noarch

     ] Following actions will be done:
do not install libreoffice-6.1.3.2-27.4.x86_64
do not install libreoffice-l10n-bg-6.1.3.2-27.4.noarch
do not install libreoffice-l10n-de-6.1.3.2-27.4.noarch
do not install libreoffice-l10n-en-6.1.3.2-27.4.noarch
do not install libreoffice-math-6.1.3.2-27.4.x86_64
do not install libreoffice-pyuno-6.1.3.2-27.4.x86_64
do not install libreoffice-writer-6.1.3.2-27.4.x86_64
do not install libreoffice-writer-extensions-6.1.3.2-27.4.x86_64
do not install libreoffice-filters-optional-6.1.3.2-27.4.x86_64
do not install libreoffice-mailmerge-6.1.3.2-27.4.x86_64


vlc-noX-2.2.6-32.8.4.x86_64 requires libmatroska.so.6(V_1.4.5)(64bit), but this requirement cannot be provided
deleted providers: libmatroska6-1.4.5-1.2.x86_64
uninstallable providers: libmatroska6-1.4.5-3.3.x86_64[download.opensuse.org-oss]
     ] do not install libmatroska6-1.4.9-4.3.1.x86_64

     ] break vlc-noX-2.2.6-32.8.4.x86_64 by ignoring some of its dependencies

     ] Following actions will be done:
downgrade of vlc-noX-2.2.6-32.8.4.x86_64 to vlc-noX-2.2.6-10.1.x86_64
downgrade of vlc-2.2.6-32.8.4.x86_64 to vlc-2.2.6-10.1.x86_64
downgrade of vlc-qt-2.2.6-32.8.4.x86_64 to vlc-qt-2.2.6-10.1.x86_64


libreoffice-kde4-6.0.5.2-24.2.x86_64 requires libreoffice = 6.0.5.2, but this requirement cannot be provided
uninstallable providers: libreoffice-6.0.5.2-24.2.x86_64[repo-update]
     ] break libreoffice-kde4-6.0.5.2-24.2.x86_64 by ignoring some of its dependencies

     ] do not install libreoffice-kde4-6.0.5.2-24.2.x86_64

     ] Following actions will be done:
do not install libreoffice-calc-6.1.3.2-27.4.x86_64
do not install libreoffice-l10n-bg-6.1.3.2-27.4.noarch
do not install libreoffice-l10n-de-6.1.3.2-27.4.noarch
do not install libreoffice-l10n-en-6.1.3.2-27.4.noarch
do not install libreoffice-math-6.1.3.2-27.4.x86_64
do not install libreoffice-pyuno-6.1.3.2-27.4.x86_64
do not install libreoffice-writer-6.1.3.2-27.4.x86_64
do not install libreoffice-writer-extensions-6.1.3.2-27.4.x86_64
do not install libreoffice-filters-optional-6.1.3.2-27.4.x86_64
do not install libreoffice-mailmerge-6.1.3.2-27.4.x86_64


libreoffice-6.1.3.2-27.4.x86_64 requires libreoffice-icon-themes = 6.1.3.2, but this requirement cannot be provided
uninstallable providers: libreoffice-icon-themes-6.1.3.2-27.4.noarch[repo-update]
     ] Following actions will be done:
do not install libreoffice-calc-extensions-6.1.3.2-27.4.x86_64
do not install libreoffice-l10n-bg-6.1.3.2-27.4.noarch
do not install libreoffice-l10n-de-6.1.3.2-27.4.noarch
do not install libreoffice-l10n-en-6.1.3.2-27.4.noarch
do not install libreoffice-math-6.1.3.2-27.4.x86_64
do not install libreoffice-pyuno-6.1.3.2-27.4.x86_64
do not install libreoffice-writer-6.1.3.2-27.4.x86_64
do not install libreoffice-writer-extensions-6.1.3.2-27.4.x86_64
do not install libreoffice-filters-optional-6.1.3.2-27.4.x86_64
do not install libreoffice-mailmerge-6.1.3.2-27.4.x86_64
     ] break libreoffice-6.1.3.2-27.4.x86_64 by ignoring some of its dependencies

     ] do not install libreoffice-icon-theme-galaxy-5.4.5.1-15.1.noarch



libreoffice-6.1.3.2-27.4.x86_64 requires libreoffice-icon-themes = 6.1.3.2, but this requirement cannot be provided
uninstallable providers: libreoffice-icon-themes-6.1.3.2-27.4.noarch[repo-update]
     ] do not install libreoffice-icon-theme-hicontrast-5.4.5.1-15.1.noarch

     ] break libreoffice-6.1.3.2-27.4.x86_64 by ignoring some of its dependencies

     ] Following actions will be done:
do not install libreoffice-draw-6.1.3.2-27.4.x86_64
do not install libreoffice-l10n-bg-6.1.3.2-27.4.noarch
do not install libreoffice-l10n-de-6.1.3.2-27.4.noarch
do not install libreoffice-l10n-en-6.1.3.2-27.4.noarch
do not install libreoffice-math-6.1.3.2-27.4.x86_64
do not install libreoffice-pyuno-6.1.3.2-27.4.x86_64
do not install libreoffice-writer-6.1.3.2-27.4.x86_64
do not install libreoffice-writer-extensions-6.1.3.2-27.4.x86_64
do not install libreoffice-filters-optional-6.1.3.2-27.4.x86_64
do not install libreoffice-mailmerge-6.1.3.2-27.4.x86_64


libreoffice-impress-6.1.3.2-27.4.x86_64 requires libreoffice = 6.1.3.2, but this requirement cannot be provided
uninstallable providers: libreoffice-6.1.3.2-27.4.x86_64[repo-update]
     ] break libreoffice-impress-6.1.3.2-27.4.x86_64 by ignoring some of its dependencies

     ] do not install libreoffice-icon-theme-sifr-5.4.5.1-15.1.noarch

     ] Following actions will be done:
do not install libreoffice-impress-6.1.3.2-27.4.x86_64
do not install libreoffice-l10n-bg-6.1.3.2-27.4.noarch
do not install libreoffice-l10n-de-6.1.3.2-27.4.noarch
do not install libreoffice-l10n-en-6.1.3.2-27.4.noarch
do not install libreoffice-math-6.1.3.2-27.4.x86_64
do not install libreoffice-pyuno-6.1.3.2-27.4.x86_64
do not install libreoffice-writer-6.1.3.2-27.4.x86_64
do not install libreoffice-writer-extensions-6.1.3.2-27.4.x86_64
do not install libreoffice-filters-optional-6.1.3.2-27.4.x86_64
do not install libreoffice-mailmerge-6.1.3.2-27.4.x86_64


kaddressbook-17.04.2-1.1.x86_64 requires kdepim-runtime, but this requirement cannot be provided
uninstallable providers: kdepim-runtime-17.04.2-1.1.x86_64[download.opensuse.org-oss]
     ] deinstallation of akonadi-4.14.10-6.5.1.x86_64

     ] do not install akonadi-runtime-1.13.0-6.5.x86_64

     ] break kaddressbook-17.04.2-1.1.x86_64 by ignoring some of its dependencies

     ] Following actions will be done:
do not install kaddressbook-17.04.2-1.1.x86_64
do not install kmail-17.04.2-3.1.x86_64



#### YaST2 conflicts list END ###

Going from 42.2 to 42.3 is an upgrade, not an update.

Best to be at a virtual console. Use CTRL-ALT-F1 for that.
Login as root.

Then run the command:

zypper dup

What you did was equivalent to “zypper up”, but you need “zypper dup” for the upgrade.

You might still get some conflicts, but there should be less. And you can still abort if you don’t know what to do with the conficts.

Before you run “zypper dup”, you could run the command “script”. That will give you a transcript of your update session in the file “typescript” in case you need to look at it later.

Hi,

I completed the update by the methodology you suggested, using zypper dup.
Unfortunately, at boot time I got grub_tpm_measure and a grub rescue> prompt.
I really am about to start crying.
I have UEFI BIOS version 8DET50WW
**UEFI BIOS DATE 2011 07 07

**I am using a dual boot system with windows 7.
I have no idea what to do next. Google told me to do a rescue disk boot, however I have no experience with that.
Any ideas are more than welcome.:’(

Boot 42.3 installation media, and choose boot from hard disk.

Some updates
I managed to create a rescue USB from Leap 42.3 using rufus.
I booted from that usb and obtained a command line prompt

https://doc.opensuse.org/documentation/leap/startup/html/book.opensuse.startup/cha.trouble.html#sec.trouble.data.recover.rescue.access
Following the examples from the link I run (the webpage in my opinion has a typo since it references the command as rootvgimport -a)

vgimport -a

this gave me the error

/run/lvm/lvmetad.socket: connect failed: No such file or directory
 WARNING: Failed to connect to lvmetad. Falling back to internal scanning

However, I was able to run lsblk and my partitions were there ,including some partitions going by the name

NAME MAJ:MIN RM SIZE  RO TYPE MOUNTPOINT  
loop0  7:0        0   58M    1  loop  /parts/mp_0000

four of them are available, to be precise. Google told me that these are virtual file systems inside another file system, whatever that means.
**I guess that something is wrong, since lsblk is no telling me the mount points, except for the loop partitions. **

This makes me really insecure. I am supposed to mount the root partition next. **Unfortunately in my case , I can’t say which is root, since lsblk does not list any mount points. **Based on the sizes, I was able to guessed correctly that my linux root partition is sda5. I was able to mount it via

mount /dev/sd5 /mnt

Can I just ignore the error form vgimport -a, and continue with the rest? I am not familiar with this procedure and would like to make sure, that the things I am doing are fine.

I would appreciate your help
Thank you in advance

Examples from the link above


FROM THE EXAMPLE
lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda           8:0    0 149,1G  0 disk
├─sda1        8:1    0     2G  0 part  [SWAP]
├─sda2        8:2    0    20G  0 part  /
└─sda3        8:3    0   127G  0 part
  └─cr_home 254:0    0   127G  0 crypt /home

mount the root


sudo mount /dev/sda2 /mnt

Mount /proc, /dev, and /sys partitions:

sudo mount -t proc none /mnt/proc
sudo mount --rbind /dev /mnt/dev
sudo mount --rbind /sys /mnt/sys

Now you can “change root” into the new environment, keeping the bash shell:

chroot /mnt /bin/bash

Finally, mount the remaining partitions from the installed system:

mount -a

all this is needed as a prerequisite of running (here sda only without a number is used. Don’t know why)

sudo grub2-install /dev/sda

UPDATE 2

Without updateing grub2 I did

sudo mount /dev/sda5 /mnt
sudo mount -t proc none /mnt/proc
sudo mount --rbind /dev /mnt/dev
sudo mount --rbind /sys /mnt/sys
chroot /mnt /bin/bash
mount -a

I checked and all of the follwing files exist.

/etc/default/grub
/boot/grub2/device.map 
/boot/grub2/grub.cfg 
/etc/sysconfig/bootloader 

ls-ltr tells me that these files are from today, except /etc/sysconfig/bootloader, which is 3 years old.

Should I just run


sudo grub2-mkconfig -o /boot/grub2/grub.cfg

and ignore


vgimport -a
/run/lvm/lvmetad.socket: connect failed: No such file or directory
 WARNING: Failed to connect to lvmetad. Falling back to internal scanning

**From what I am reading online this lvm issue is not to be ignored. **

thank you

That’s pointless, your grub fails before it can access grub.cfg. Start with telling whether you are using legacy BIOS or EFI boot. In case of legacy BIOS, run bootinfoscript (GitHub - arvidjaar/bootinfoscript) and provide RESULTS.txt (upload to susepaste.org). In case of EFI provide output of “efibootmgr -v”.

the results from bootinfo are included below
https://susepaste.org/5576780

efibootmgr -v gives the error EFI variables are not supported on this system. I guess i have legacy bios.

Can you also show /etc/default/grub_installdevice from your root partition?

The requested output reads

cat /etc/default/grub_installdevice
/dev/disk/by-id/wwn-0x5000c50052c57048-part3
activate

So your openSUSE is configured to put grub in partition 3 and that is where updated grub was written. At the same time you have grub in MBR of your drive and that is what is actually used during boot by BIOS. This grub instance was not updated, so now code in MBR does not match the rest if grub binaries under /boot/grub2.

You also have rather strange active partition 5 which is logical partition (so normally cannot be used as boot partition by BIOS) and does not contain any boot code so would not work even with Syslinux MBR that does support it.

At this point you need to decide whether you want to leave grub in MBR or you want leave it as configured in partition 3 and install generic code in MBR. If you ever need or want to boot Windows directly (not via grub) you need generic code that allows booting Windows by changing active partition.

P.S. for the future - open new thread for new problem. It is very unlikely that people who are interested in grub will be attracted by the title “conflicts when updating”, if only by accident. And even then they probably stop reading after original post. The more precise subject you give the more chances you attract attention of the right people.

Hi again,

first of all I would like to thank you for taking your time to read all my threads and help me this issue.

I am not that knowledgeable with linux to give you an educated answer. What I would like to have is to be able, to choose between windows 7 and suse leap 42.3 from the grub menu as before. If it is possible to leave grub in the MBR, this is fine with me. In general, I would say that I am fine with any solution which would not wipe my data. If I would have to move grub from the MBR this is is also fine, as long as I won’t have to reinstall windows and linux. Basically, I am open to your suggestions and hope that the issue with GRUB is fixable. i am getting scared tight now.

The reason for the strange configuration can be found in the forum link below. I was having problems with my dual boot and most probably, something went wrong there.
P.S.
Thank you for your advice. I would take note and not mix questions in the future.

https://forums.opensuse.org/showthread.php/508264-Dual-boot-windows-8-and-opensuse-the-boot-loader-was-wrongly-set-to-grub2/page4?highlight=john_snow

Hi, I opened a new thread to address the grub issue as you suggested.

The link is

https://forums.opensuse.org/showthread.php/534675-GRUB-problem-after-updating-to-Leap-42-3-(dual-boot-system)?p=2892306#post2892306