Conflicting versions of a package in two repos

Hi everyone,
I probably messed up again. I’m the author of the application xflr5 used for aerodynamic design : https://sourceforge.net/projects/xflr5/

I’ve managed to package version 6.30, as part of the science project.
https://build.opensuse.org/package/show/science/xflr5

The package has been moved to the Factory which is fine:
https://software.opensuse.org/download.html?project=openSUSE%3AFactory&package=xflr5

The problem is that there is still an old version 6.10 herehttps://software.opensuse.org/package/xflr5
This version is obsolete and is also the default proposed in the Leap distribution.

Does somebody know how to resolve this ?

Thanks,

André

Hi
Maintenance update if you want to get it to Leap 42.1;
https://en.opensuse.org/openSUSE:Package_maintenance

Thanks Malcom,
Still need a bit of help.


techwinder@linux-9sh0:~/osc/science/xflr5> osc mr
Using target project 'openSUSE:Maintenance'
Server returned an error: HTTP Error 400: Bad Request
Maintenance incident request contains release target project openSUSE:Factory with invalid projectkind "standard" for package 4ti2
techwinder@linux-9sh0:~/osc/science/xflr5> osc sr
Server returned an error: HTTP Error 400: Bad Request
The request contains no actions. Submit requests without source changes may have skipped!

Both “osc mr” and “osc sr” fail.
What is it that I’m doing wrong ?

On Sat 10 Dec 2016 05:06:01 PM CST, techwinder wrote:

Thanks Malcom,
Still need a bit of help.

Code:

techwinder@linux-9sh0:~/osc/science/xflr5> osc mr
Using target project ‘openSUSE:Maintenance’
Server returned an error: HTTP Error 400: Bad Request
Maintenance incident request contains release target project
openSUSE:Factory with invalid projectkind “standard” for package 4ti2
techwinder@linux-9sh0:~/osc/science/xflr5> osc sr Server returned an
error: HTTP Error 400: Bad Request The request contains no actions.
Submit requests without source changes may have skipped!

Both “osc mr” and “osc sr” fail.
What is it that I’m doing wrong ?


osc maintenancerequest  SOURCEPROJECT  SOURCEPACKAGES RELEASEPROJECT ] ]

So from your development project to the released project.


Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-38-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!