conflict LibreOffice - VirtualBox - openSUSE

I experience a bug.

However, I do not know if it is caused by LibreOffice, VirtualBox or by the OS (openSUSE) itself.

LibreOffice does run fine under openSUSE 12.1.

However, as soon as I run VirtualBox, LibreOffice looses the background color on menu bar, icon bar, menus, pop-ups (like Preferences, Print, etc.) and so on.
Moreover, the text (on Menus, pop-ups, etc.) doesn’t get refreshed, all text is “rendered” above each other.
Hence all is unreadable within a moment.

I presently run
– openSUSE 12.1 (all packages patched up-to-date),
… with Mesa (7.11-11.1.2),
… with xorg-x11-driver-video-nouveau (0.0.16_20110720_b806e3f-2.1.2)
– VirtualBox 4.1.8 (tried both, Oracle Repo and openSUSE Repo),
– LibreOffice 3.4.4 (the latest stable within the openSUSE repos)

– MB: ASUS M2N-MX*, with AMD Athlon™ 64 X2 Dual Core Processor 3800+, 6GB RAM
…*nVidia GeForce 6100 nForce 430 (Chipset w integrated GPU)

Any advice is very much appreciated.

(Moderator: Please feel free to move to appropriate Sub-Forum.)

Greetings from Switzerland,

So to clarify the problem please answer these:

  1. openSUSE 12.1 is the host running Virtual Box (Yes/No)?
  2. LibreOffice is running on the Host or the Guest VM?
  3. what Guest VM OS are you running in VirtualBox?
  4. Have you ever tried loading the proprietary nVIDIA video driver?

I am not sure who you would post this bug report to. VirtualBox, openSUSE or is it a graphic problem with your hardware?

Thank You,