Configuring Wireless USB

I’m totally new to Linux and need some help in baby steps. I have a Wireless USB which works just fine under Windows, but I have no idea how to make it work under Linux. I have the CD with a Linux driver, so I know it’s capable, but can’t find a starting hint on how to do this. I’ve looked through many of the posts here, but can’t find the answer.

Any help would be greatly appreciated! Thanks in advance.

I should have mentioned:

openSUSE 11.1
RALink RT73(RT2571W) USB Wireless Lan

Did you read the stickies at the wireless forum?
Wireless - openSUSE Forums

I noticed them after I started hunting around - but it’s getting late and I’m ready to knock off til tomorrow. I did notice that the USB adapter is working and it can successfully ping itself, but not the gateway or beyond, so this is a step in the right direction.

As someone on one of the forum answers said “you mean with this Linux thing, I’m going to have to learn to type again?”

I tried to follow some of the Mfr’s ReadMe steps, but it’s all so new to me, that it’s just knocking me out. (Well, that and the Turkey which they say doesn’t make you tired, but that’s why they’re them and we’re us…)

I’ll read through the posts tomorrow, but if some kind soul wants to take pity on this lost and ignorant (and frankly, undeserving) pseudo-computer user, I’d be deeply graetful for any hints on the RA-LINK WLan USB logical connection steps to configuring this card, I’ll be your best friend!

Thanks.

Thanks for pointing me to the steps to follow. Unfortunately, after going through each one, get no logical connection between my wlan0 and anything that requires an internet connection. I’ve pasted the output - sorry about the length… but, bottom line is that I show packets flowing between wlan0 and the internet, as well as eth1 when I connect that cable, but only eth1 gets a valid/logical connection, where wlan0 does not. Devices/Network Tools shows the packets flowing with eth1 cable unplugged, but Firefox gets nothing… strange…

linux-q7ir:~/Desktop # /usr/bin/lsusb
Bus 007 Device 005: ID 148f:2573 Ralink Technology, Corp. RT2501USB Wireless Adapter
Bus 007 Device 003: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 002: ID 041e:4058 Creative Technology, Ltd Live! Cam Optia AF
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 003: ID 046d:c517 Logitech, Inc. LX710 Cordless Desktop Laser
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 043d:0098 Lexmark International, Inc. 7100 Series
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

dmesg | less

usb 7-5.4: new high speed USB device using ehci_hcd and address 4
usb 7-5.4: configuration #1 chosen from 1 choice
usb 7-5.4: New USB device found, idVendor=148f, idProduct=2573
usb 7-5.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 7-5.4: Product: 802.11 bg WLAN
usb 7-5.4: Manufacturer: Ralink
usb 5-2: new low speed USB device using uhci_hcd and address 3

Registered led device: rt73usb-phy0::radio
Registered led device: rt73usb-phy0::assoc
Registered led device: rt73usb-phy0::quality
usbcore: registered new interface driver rt73usb
Adding 2093048k swap on /dev/mapper/system-swap. Priority:-1 extents:1 across:2093048k
loop: module loaded

firmware: requesting rt73.bin
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: authenticate with AP 00:24:56:da:7a:f9
wlan0: authenticated
wlan0: associate with AP 00:24:56:da:7a:f9
wlan0: RX AssocResp from 00:24:56:da:7a:f9 (capab=0x431 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present
bootsplash: status on console 0 changed to on
SFW2-INext-DROP-DEFLT IN=eth1 OUT= MAC= SRC=192.168.2.17 DST=224.0.0.251 LEN=65 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=45
SFW2-INext-DROP-DEFLT IN=wlan0 OUT= MAC= SRC=192.168.2.17 DST=224.0.0.251 LEN=65 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=45
martian source 192.168.2.255 from 192.168.2.12, on dev wlan0
ll header: ff:ff:ff:ff:ff:ff:00:1b:77:92:02:8a:08:00
mtrr: type mismatch for d0000000,10000000 old: write-back new: write-combining
SFW2-INext-DROP-DEFLT IN=wlan0 OUT= MAC= SRC=192.168.2.17 DST=224.0.0.251 LEN=65 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=45
SFW2-INext-DROP-DEFLT IN=eth1 OUT= MAC= SRC=192.168.2.17 DST=224.0.0.251 LEN=65 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=45

martian source 192.168.2.17 from 192.168.2.1, on dev wlan0
ll header: ff:ff:ff:ff:ff:ff:00:24:56:da:7a:f9:08:06
martian source 192.168.2.17 from 192.168.2.1, on dev wlan0
ll header: ff:ff:ff:ff:ff:ff:00:24:56:da:7a:f9:08:06
SFW2-INext-DROP-DEFLT IN=wlan0 OUT= MAC= SRC=192.168.2.17 DST=224.0.0.251 LEN=65 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=45
martian source 192.168.2.255 from 192.168.2.12, on dev wlan0
ll header: ff:ff:ff:ff:ff:ff:00:1b:77:92:02:8a:08:00
SFW2-INext-DROP-DEFLT IN=wlan0 OUT= MAC= SRC=192.168.2.17 DST=224.0.0.251 LEN=153 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=133
SFW2-INext-DROP-DEFLT IN=eth1 OUT= MAC= SRC=192.168.2.17 DST=224.0.0.251 LEN=214 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=194
martian source 192.168.2.17 from 192.168.2.1, on dev wlan0
ll header: ff:ff:ff:ff:ff:ff:00:24:56:da:7a:f9:08:06
martian source 192.168.2.17 from 192.168.2.1, on dev wlan0
ll header: ff:ff:ff:ff:ff:ff:00:24:56:da:7a:f9:08:06
martian source 192.168.2.255 from 192.168.2.12, on dev wlan0
ll header: ff:ff:ff:ff:ff:ff:00:1b:77:92:02:8a:08:00
sky2 eth1: Link is up at 1000 Mbps, full duplex, flow control both
ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
martian source 192.168.2.17 from 192.168.2.1, on dev wlan0
ll header: ff:ff:ff:ff:ff:ff:00:24:56:da:7a:f9:08:06
martian source 192.168.2.17 from 195.135.221.130, on dev eth1
ll header: 00:26:18:14:b4:cc:00:24:56:da:7a:f9:08:00
martian source 192.168.2.17 from 195.135.221.130, on dev eth1
ll header: 00:26:18:14:b4:cc:00:24:56:da:7a:f9:08:00
martian source 192.168.2.17 from 195.135.221.130, on dev eth1
ll header: 00:26:18:14:b4:cc:00:24:56:da:7a:f9:08:00
martian source 192.168.2.17 from 192.168.2.1, on dev wlan0
ll header: ff:ff:ff:ff:ff:ff:00:24:56:da:7a:f9:08:06
martian source 192.168.2.17 from 192.168.2.1, on dev wlan0
ll header: ff:ff:ff:ff:ff:ff:00:24:56:da:7a:f9:08:06

linux-q7ir:~/Desktop # /usr/sbin/iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 no wireless extensions.

pan0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:“MLSM”
Mode:Managed Frequency:2.427 GHz Access Point: 00:24:56:7A:F9
Bit Rate=54 Mb/s Tx-Power=9 dBm
Retry min limit:7 RTS throff Fragment thr=2352 B
Encryption key:54C7-66A5-488E-0CA0-6EAF-BD23-F966-BCD3-77F7-23A0-7A9F-9073-D79E-1D60-ABA7-0978 [2] Security mode open
Power Managementoff
Link Quality=38/100 Signal level:-64 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

linux-q7ir:~/Desktop # sudo /usr/sbin/iwlist scan
lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

eth1 Interface doesn’t support scanning.

pan0 Interface doesn’t support scanning.

wmaster0 Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:24:560A:7A:F9
ESSID:“MLSM”
Mode:Master
Channel:4
Frequency:2.427 GHz (Channel 4)
Quality=47/100 Signal level:-74 dBm
Encryption keyon
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=0000000e34e41303
Extra: Last beacon: 512ms ago
Cell 02 - Address: 00:25:9C:4D:B3:9B
ESSID:“P”
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=46/100 Signal level:-82 dBm
Encryption keyon
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:tsf=0000005438ca5d8b
Extra: Last beacon: 436ms ago

Your wireless has connected. If you don’t get Internet access, then
you either have a problem with routing, or DNS.

What do you see with ‘/sbin/route -n’?

What does ‘cat /etc/resolv.conf’?

Compare the results for both with the wired and wireless connected.

*I get essentially the same thing, except that eth1 works and wlan0 doesn’t. It must be something simple in terms of what a linux user ought to know, but to quote an old quote, “I don’t have the brains of a ice cube”…

Not sure what to do next…

linux-q7ir:~/Desktop # /sbin/route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.2.1 0.0.0.0 UG 0 0 0 wlan0
linux-q7ir:~/Desktop # cat /etc/resolv.conf

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

search gateway.2wire.net
nameserver 192.168.2.1
linux-q7ir:~/Desktop # /sbin/route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.2.1 0.0.0.0 UG 0 0 0 eth1
linux-q7ir:~/Desktop # /sbin/route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.2.1 0.0.0.0 UG 0 0 0 eth1
linux-q7ir:~/Desktop # cat /etc/resolv.conf

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

search gateway.2wire.net
nameserver 192.168.2.1
linux-q7ir:~/Desktop #

With the kNM applet, select “Manage Connections” => Network Connections
=> Wireless. Choose your AP, then Edit. Select IP Address and pull down
the “Basic Settings” to “Routes”. Uncheck both boxes.

I’m running Gnome, so unable to run KDE commands (I assume that’s what those were in your last post), but have now noticed that while both eth1 and wlan0 are both actually handling packets, eth1 now only works when I remove the wlan0 adapter from the usb port…

I also tried to download/install KDE and am getting errors I don’t understand yet how to fix, so am basically stuck. I appreciate your help though.

After a reinstall of Linux, using KDE as my interface/desktop, I’ve now solved the problem and have my system running on my wireless USB.

The interesting thing, and reasons for repost:

  • Being new to this is really tough - some of the instructions only make sense after you’ve solved the problem (what isn’t this way with something totally new to you?)
  • The post that syampillai directed me to as a starting point was critical, especially to a new Linux user and stopped me from making more annoying posts that were unlikely to get a response (thank you syampillai!)
  • KDE seems much easier to manage a system under for a first time user. Without the directions sent by lwfinger on how to fix, I wouldn’t have solved the problem, and these directions were for KDE - hence my decision to reinstall since I couldn’t figure out how to get to KDE from Gnome although I should have been able to do so…(again, thank you lwfinger!)
  • Now that I have things up and running the exploration can begin and that means a thousand more things to learn, but at least I’ve got the experience of learning how to solve a first problem, and knowing the importance of having a helpful forum to turn to - these days, anything new requires a good forum to support it.

Thanks again for all the help. I hope I haven’t worn out my welcome!

Hi, and welcome :slight_smile:

It may help to take a look at these useful links as recommended by oldcpu:

openSUSE 11.2 Is very good! Thank you! - openSUSE Forums

Thanks for these - I’ll take a look over the weekend, but the help is really appreciated. It looks like those ref docs should give me a whole lot of needed info.