Configuring Wacom tablet drivers

I beg you, no complains that I could have found this in the internet, I tried looking but I can’t start anything with the information there, Im still a n00b and can’t start anything with those infos…

<sigh>

The Linux Wacom Project

"On kernel versions 2.6.8 or later, you can link Wacom USB tablet to “/dev/input/wacom”. It can be done by adding the following rules in /etc/udev/rules.d/60-wacom.rules. Some distributions use a different number for the file name. Please look for proper one with wacom under /etc/udev/rules.d.

KERNEL=="event*", ATTRS{idVendor}=="056a", SYMLINK="input/wacom" 

On older kernels, SYSFS is used instead of ATTRS. "

Well regretfully no matter if I pick SYSFS or ATTRS… it doesn’t work! I get

bash: SYSFS{idVendor}==056a,: command not found

Only explanation for this I have is that I’ve installed it the false way… but in the readme file, there is an option, I think it might be of help, but the commands written down have some syntax error… please help

However, if you have a USB tablet which is newer than your running kernel, i.e., the tablet is not supported by your running kernel, or you are a developer who is willing to build the driver from the source, there are extra work waiting for you.

==============================================================================

BUILDING FROM TARBALL:

As you would expect, run configure and make. Configure options are explained below.

$ ./configure && make

==============================================================================

CONFIGURE OPTIONS:

This file contains hints for building the sources. There are a number of
build targets, some of which are not built automatically. Here is the
breakdown:

  wacom.o: not built by default (--enable-wacom, --disable-wacom)
  wacdump: built by default (--enable-wacdump, --disable-wacdump)
    hid.o: not built by default (--enable-hid, --disable-hid)
  evdev.o: not built by default (--enable-evdev, --disable-evdev for kernel 2.4.x only)

mousedev.o: not built by default (–enable-mousedev, --disable-mousedev. It is used for kernel 2.4.x only)
usbmouse.o: not built by default (–enable-usbmouse, --disable-usbmouse. It is used for kernel 2.4.x only)
input.o: not built by default (–enable-input, --disable-input. It is used for kernel 2.4.x only)
wacom_drv.o: built by default (–enable-wacomdrv, --disable-wacomdrv)

There are many options, and configure will attempt to guess the correct
values for most of them. By default, only wacomcpl, xsetwacom, wacom_drv.o,
xidump, and wacdump program are built.

Hi
There is a HowTo in the howto section called;

“Wacom tablet under openSUSE 11.0” by user VladimirSavic.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-4-default
up 2:17, 1 user, load average: 0.37, 0.20, 0.21
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82

Hi Farel;

Can you tell us how we can help you? (it is still not clear to me how much of your post is seeking help, or is posting an explanation …)