Configuring sound devices on teamspeak2

I have never use linux before and I just put Suse 10.3 onto my computer yesterday. I’m now having to download and install my previous application. My first application that I downloaded and installed was TeamSpeak2. When I opened the application up and connected to the appropriate server and tried to talk I noticed that I could here anything or say anything. At that point of time I noticed that it my be my headset so I decided to set up skype. Once I setup skype I called a friend and it worked like a charm.

I then went back to teamspeak and went to the options drop down menu and noticed that for some reason I wasnt able to choose a sound input and output device. It turned out that the TeamSpeak 2 for linux is missing a couple of features that the Windows version had. Now on the drop down options menu is a category for sound drivers. The sound driver’s category includes “default”, “default network” and “other”. Now I am assuming that’s what I need to fix in order for me to talk, but if anybody can help then I would appreciate it.

I’m not sure if it makes a difference, but I’m using a Dynex USB PC Headset.

Teamspeak uses OSS, if I’m not mistaken. There are ways of getting it to work with alsa, but they’re not really practical for new Linux users.
If you wait a little while, Teamspeak 3 will be released, which will support alsa.

You really should consider installing openSuSE 11. 10.3 is the previous version.