Configuring Mobile Broadband Hub to allow SIP numbers to register in connected Fritz Box

Hi there,

I have recently moved to the UK and have brought my Fritz Box Fon WLAN 7170 along. We are living in temporary accommodation so, rather then getting a landline connection, I am using a Huawei E5151 Mobile WiFi hotspot and a local SIM card with unlimited data allowance. This is connected via a LAN cable to the Fritz Box.

So far, so good. I am connected to the internet and can send and receive emails no problem. Even Skype and Internet Calls (desktop app) work perfectly.

My problem is that the two SIP numbers I have configured in the Fritz Box are not registering. Having changed the local settings, I removed the SIP numbers, then reloaded and reconfigured them but no joy.

I suspect that there’s a setting in the mobile hotspot that I haven’t configured but I have no idea as to where to start.

Can anyone help?


I don’t know the specifics of a Fritz box and whether it’ a true hub or something else, but you should know that SIP is a special type of protocol to support the special needs of applications that need to be “location aware”

SIP needs to identify every Host with a special ID which is publicly accessible which is why by default SIP has major issues functioning through proxies and NAT.

To address these issues, typically special SIP proxies are used. In the old days, they had to be installed on the device causing the problem allowing a kind of special bypass. Nowadays, SIP proxies can be located anywhere on the Internet and know how to penetrate problem devices.

Skype is not affected by SIP issues because it uses a proprietary protocol that rides on top of http.
Don’t know if the “Internet calls” you’re referring to are Skype or something else.