Configuring Microphone

Hello, everybody, I am a new in linux. I’ve installed opensuse 11 with KDE 4 on my Toshiba Satellite A200 laptop and solved all the troubles I had except the microphone. It just doesn’t work neither in sound recording software, neither in skype. I’ve discovered that it’s a quite common issue, but the advices I found either don’t work, either I just cannot understand what I should do. Except microphone all sound settings work perfectly. When I try to play with capturing, I have only noises in my speakers. Please, if anyone knows how to solve that problem, give a guide to that.

I know of no specific guide for this. That is because most audio hardware offers different control options for the audio, and hence different mixer appearance and different mixer controls. Thus every solution tends to be specific to the specific hardware and hence its not easy to create one guide for all.

My experience is most user problems with the microphone are either:
a. due to bad mixer settings, or
b. due to hardware being new, and one needing newer alsa versions.

When I test my mic, I typically use a simple arecord command. ie something likearecord -d 10 myrecording.wavorarecord -d 10 -f cd secondrecording.wavwhere “-d 10” sets a 10 second recording. I then play back the recording with xine or mplayer or xmms (or any audio playback program).

When advising of the results of that, please make it clear as to whether you were trying your Internal mic or your external mic.

If while recording audio with the basic “arecord” does not work, then we need more information on your hardware/software audio configuration and on your mixer. To provide more information, then with your PC connected to the internet, please copy and paste the following into a gnome-terminal / konsole:

wget && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following, one line at a time, into a gnome-terminal or konsole and post the output here.
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Good luck.

Since you note you are new to Linux, here is a general openSUSE linux concepts guide you might find worth reading: Concepts - openSUSE

Reading that guide will NOT directly solve your mic configuration problem, but it might provide more information on how things are done in Linux to provide a basis for better understanding and solutions for possible other aspects.

Thank you for quick reaction, ok, I will try that you’ve told, just a little bit later =).

Well I’ve just solve a same problem on my dell.
Configure the sound in the control panel, try to change all the 4 default sound drivers from “auto detected” to “ALSA”, then restart the system.
This actually solved my problem but I’m not sure whether it works on other laptops.
Good Luck!

Ok, the procedure with the tsalsa gave that url and I was asked to put it in #alsa, however I am not very sure what to do with that: tsalsa.txt - (beta).

The following output for the rpm queries:

  1. rpm -qa | grep alsa
    2)rpm -qa | grep pulse - no matches
    3)rpm -q libasound2
    4)uname -a
    Linux belousov-roman #1 SMP 2008-08-21 00:34:25 +0200 i686 i686 i386 GNU/Linux
    5)cat /etc/modprobe.d/sound
    options snd slots=snd-hda-intel,snd-hda-intel

NXNs.JPS6WT8bfU4:RV630/M76 audio device [Radeon HD 2600 Series]

alias snd-card-0 snd-hda-intel

u1Nb.GXavFDgt6N2:82801H (ICH8 Family) HD Audio Controller

alias snd-card-1 snd-hda-intel

The tool arecord produced files with noise for both variants of calls.

So, I have internal mic, and I am testing it at the moment, I also have one input jeck for microphone and one headphones jeck.

So with that info given, do you have any idea what I should do?
Thank you in advance.

To kukunny: thanks for your advice however your way seems to me too risky =).

That was a surprise. Did you remove pulse audio?

That was also a bit surprising, as alsa identifies two sound devices in your toshiba.

Makes me think you are very close.

The internal mic is typically much much more difficult to get working than an external mic.

Anyway, lets try a model option in your /etc/modprobe.d/sound file. I note the following options for an ALC268 (which is in your Toshiba A200) from the ALSA-Configuration.txt file:

	  3stack	3-stack model
	  toshiba	Toshiba A205
	  acer		Acer laptops
	  dell		Dell OEM laptops (Vostro 1200)
	  zepto		Zepto laptops
	  test		for testing/debugging purpose, almost all controls can
			adjusted.  Appearing only when compiled with
	  auto		auto-config reading BIOS (default)  

Try modifying your /etc/modprobe.d/sound file to:

options snd slots=snd-hda-intel,snd-hda-intel
# NXNs.JPS6WT8bfU4:RV630/M76 audio device [Radeon HD 2600 Series]
alias snd-card-0 snd-hda-intel
# u1Nb.GXavFDgt6N2:82801H (ICH8 Family) HD Audio Controller
alias snd-card-1 snd-hda-intel
options snd-hda-intel model=3stack

then restart your alsa with **su -c ‘rcalsasound restart’**and then test your mic. Pay close attention to your mixer settings, as you may need to adjust them.

If that does not work, try replacing “3stack” with “toshiba” and restart your alsa (per above), test your mic and be certain to check your mixer. If that does not work you can also repeat the process with: auto, acer, dell, zepto, using the same method as above.

Hallo, again!

Well, the 3stack model did no changes, but the toshiba variant changed the channels set. Record tests produce a lot of noice, however I hear what I am saying, though the noise is annoying, I’ll try to adjust sound to eliminate that. Thank you very much, I hope it’ll succeed.

As for pulse, no, I haven’t uninstalled it on purpose, though I configured the software set during installation. But in fact, except office tools and java, I have just added some tools, I didn’t unchecked any, if they do not depend on java or office tools. Couldn’t it be 'cause of KDE desktop? And what is pulse anyway?

And yes, two cards there may be, because I have tv capabilities, it seems the second card is integrated along with the graphic card of ATI Radeon.

And I am sorry, I have a question out of topic, I’ve changed the files /etc/Hosts and /etc/HOSTNAME to produce a more meaningful names for my machine, but consequantly (I guess) I cannot launch my file managers (neither Dolphin, neither Konqueror). Maybe I should change some other files as well for them?

Again, thank you very much, I feel really happy now =)

I recommend you change them back to the way they were before. There is another (better) way to change the host name via YaST.

I recommend you start a new thread on that subject/question. I’m currently “on the road” and do not have access to my notes, and I have a horrible memory, so I can’t give you the solution to that off the top of my head (I do recall the solution is fairly easy - I think it is under YaST > Network Devices > Network card, but I’m not sure, … best to ask first).

Good luck in your noise reduction efforts. Its possible the capture levels need adjustment.

I have read of cases for other audio codecs where the driver was not very good and there was noise, and after the alsa developers learned of it, they were able to adjust the driver to reduce the noise.

I searched on your ALC268 and noted there are updates for the ALC268, albeit none of them mention noise:
Search results for ALC268 - AlsaProject

If you decide you wish to try an update to alsa, let me know and I can point you to some rpms that you can easily install via zypper commands (I can give the precise commands).

And if that does not work, then write a bug report on openSUSE and the alsa driver, to bring to the attention of the developers that the noise levels are unsatisfactory. Again, I can provide the links to a couple of web sites that provide guidance on how to write the bug reports.

Good luck!

Well, yes, the problem was solved completely by adjusting capture and boost settings, it’s perfect now =). But restarting the alsa service caused other little problem: the Kmixer applet is not loaded automatically anymore, I just wonder now how to make it work as before =).
As for hostname, yep, I already found hostname utility and see that I was wrong to make it as I did =).
Anyway, now everything works in my laptop, that’s cool, thank you.

Hi again.

I decided to change my desktop to Gnome and all this procedure failed, I cannot see, why it should be different for that =(.

Gnome’s audio set up is different than KDE’s.

Some sound concepts:
Sound-concepts - openSUSE

I don’t use gnome, so I do not think I can provide specific help without wild speculation, which I do not want to do. You will need to repost all your information again, detailing the audio aspects of your current Gnome/openSUSE setup.

Ah, so, but I wonder, if you like so much KDE, which version do you use? Because I used the 4.0, while it was refferenced to as not matured, well, up to my mind it seems to be truth, 'cause changing via Yast some preferrences caused crashes to applications. For instance, I just changed my name account, and the .kde links were not updated, it crashed autologin. Though I like its appearance I decided to start with simpler things.

On openSUSE-11.0 I use kde-3.5.9. On openSUSE-10.3 I use kde-3.5.7.

I do have a test PC running openSUSE-11.1 beta2 (with kde-4.1.2) and it appears much much better than openSUSE-11.0’s kde-4.0.4. BUT openSUSE-11.1 beta2 has other bugs that need sorting, so best wait until mid-Dec before installing 11.1.

Thanks. Well maybe if it appears to be never simpler, I will get back to KDE but the 3rd one possibly =).